Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Moderator: fracz

radasx
Posts: 5
Joined: Sat Dec 08, 2018 11:11 pm

Post

pzygmunt wrote: Mon Mar 23, 2020 8:26 am Sprawdzałeś logi ?
BŁĄD
Wystąpił problem w trakcie komunikacji z serwerem. Spróbuj ponownie za chwilę.


INFORMACJA
Logowanie tymczasowo niedostępne. Spróbuj ponownie później.
User avatar
pzygmunt
Posts: 18604
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

Chodziło mi logi z usług.
radasx
Posts: 5
Joined: Sat Dec 08, 2018 11:11 pm

Post

pzygmunt wrote: Mon Mar 23, 2020 4:04 pm Chodziło mi logi z usług.
Gdy wyłączę apache2 wszystko działa. Gdy włączę apache2 dostaje zwrotkę o zajętości portu 443.
User avatar
pzygmunt
Posts: 18604
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

Zapewne więcej usług niż jedna chce używać 443 lub 80
radasx
Posts: 5
Joined: Sat Dec 08, 2018 11:11 pm

Post

pzygmunt wrote: Thu Mar 26, 2020 10:12 pm Zapewne więcej usług niż jedna chce używać 443 lub 80
To właśnie napisałem. Potrzebuje informacji w jaki sposób mogę ten port zmienić. Jeśli przestawię na proxy to działa. Pytanie tylko jak skierować proxy na nie.

@edit

Udało się postawić na innym porcie. Pytanie tylko w jaki sposób przekierować strone z ssl port :444 żeby nie wyrzucało błędu o certyfikatach?

@@edit2

Certyfikaty ogarnąłem. Nie wiem tylko w jaki sposób mogę dokonać wskazań domeny aby zamiast korzystać z https://domena.com:444 działała https://domena.com


"Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.""

@@edit3

SSLProxyEngine nie wpisałem ;)
User avatar
Goral64
Posts: 3152
Joined: Fri Dec 27, 2019 6:22 pm
Location: Żerniki Wrocławskie

Post

Niestety, nie odświeżyło mi certyfikatów z Let's Encrypt... Nie mam konceptu dlaczego...
Ktoś miał podobny problem i jakoś go rozwiązał?
Widzimy się na Supla Offline Party Season 2 :D

Image
User avatar
lesny8
Posts: 2851
Joined: Mon Dec 11, 2017 9:43 pm

Post

TCP 80 otwarty?
Czekam na kolejne Supla Offline Party 👍
User avatar
Goral64
Posts: 3152
Joined: Fri Dec 27, 2019 6:22 pm
Location: Żerniki Wrocławskie

Post

lesny8 wrote: Sun Apr 19, 2020 10:28 pmTCP 80 otwarty?
Otwarty, ale przy mojej konfiguracji to cholera wie, gdzie to wszystko trafia :(
Z FunBoksa idzie na malinę, na której jest cała instalacja.
W styczniu jakoś udało się zainstalować oba certyfikaty ale w kwietniu po 90 dniach się nie odnowiły :(

EDIT:
Niestety, między funboksem a maliną jest jeszcze inne proxy na nginx :(
Widzimy się na Supla Offline Party Season 2 :D

Image
User avatar
Goral64
Posts: 3152
Joined: Fri Dec 27, 2019 6:22 pm
Location: Żerniki Wrocławskie

Post

OK, sprawa załatwiona. Certyfikaty się wygenerowały i już działają. Musiałem je tylko skopiować na pierwsze proxy.
Widzimy się na Supla Offline Party Season 2 :D

Image
User avatar
lesny8
Posts: 2851
Joined: Mon Dec 11, 2017 9:43 pm

Post

Goral64 wrote: Mon Apr 20, 2020 7:31 pm OK, sprawa załatwiona. Certyfikaty się wygenerowały i już działają. Musiałem je tylko skopiować na pierwsze proxy.
To git majonez :)
Czekam na kolejne Supla Offline Party 👍

Return to “supla-docker”