Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Moderator: fracz

effendi
Posts: 165
Joined: Wed Apr 26, 2017 9:36 am

Post

Witam, próbuję skonfigurować proxy na malinie, domena noip, kontenery startują:

Code: Select all

pi@SUPLA:~ $ docker ps
CONTAINER ID        IMAGE                                                 COMMAND                  CREATED             STATUS              PORTS                                      NAMES
bbface5d6b07        lesny8/rpi-docker-letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   9 minutes ago       Up 44 seconds                                                  nginx-letsencrypt
cbe6ed3c0e39        lesny8/rpi-docker-gen                                 "/usr/local/bin/dock…"   9 minutes ago       Up 43 seconds                                                  nginx-gen
335b2224091e        nginx                                                 "/docker-entrypoint.…"   9 minutes ago       Up 45 seconds       0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp   nginx-web
25ba693795e2        supla/supla-server:arm32v7                            "/usr/bin/server-ent…"   18 hours ago        Up 45 seconds       0.0.0.0:2015-2016->2015-2016/tcp           supla-server
9c2f528e2d91        supla/supla-cloud:arm32v7                             "docker-php-entrypoi…"   18 hours ago        Up 43 seconds       80/tcp                                     supla-cloud
6117f38966e9        hypriot/rpi-mysql:5.5                                 "/entrypoint.sh mysq…"   18 hours ago        Up 44 seconds       3306/tcp                                   supla-db
- porty odblokowane i przekierowane (1:1).
- po wpisaniu adresu otrzymuję komunikat:
503 Service Temporarily Unavailable
Pomożecie?
Pogodynka >>
User avatar
michael
Posts: 1301
Joined: Wed Nov 09, 2016 8:00 am
Location: Wojkowice

Post

Nie wiem czy to będzie miało związek, ale dzisiaj również miałem problem z odnowieniem certyfikatów.

Twój błąd wskazuje na serwis czasowo niedostępny. Może po prostu spróbuj później ;)
:mrgreen: :mrgreen: :mrgreen:
User avatar
lesny8
Posts: 2851
Joined: Mon Dec 11, 2017 9:43 pm

Post

effendi wrote: Thu Jul 09, 2020 6:32 am ...
- porty odblokowane i przekierowane (1:1).
- po wpisaniu adresu otrzymuję komunikat:
503 Service Temporarily Unavailable
Pomożecie?
Jaki adres? Adres IP czy nazwe domeny?
Czekam na kolejne Supla Offline Party 👍
effendi
Posts: 165
Joined: Wed Apr 26, 2017 9:36 am

Post

W obu przypadkach ten sam komunikat :(
Pogodynka >>
User avatar
lesny8
Posts: 2851
Joined: Mon Dec 11, 2017 9:43 pm

Post

W pliku env masz wpisana nazwę domeny?
Czekam na kolejne Supla Offline Party 👍
effendi
Posts: 165
Joined: Wed Apr 26, 2017 9:36 am

Post

Code: Select all

# Where the SUPLA Cloud will be accessible? Put domain or IP address here with port.
CLOUD_DOMAIN=xxxxxxxxxxx.org:443

# Initial user account details; delete these settings after the first launch
FIRST_USER_EMAIL=xxxxxxxxxxxxxxxx
FIRST_USER_PASSWORD=xxxxxxxxxxxxxxx

# Google ReCaptcha settings
RECAPTCHA_ENABLED=false
RECAPTCHA_PUBLIC_KEY=
RECAPTCHA_PRIVATE_KEY=

# Mailer settings (SMTP)
MAILER_HOST=xxxxxxxxx
MAILER_PORT=465
MAILER_USER=xxxxxxxxxxxxxx
MAILER_PASSWORD=xxxxxxxxxxxx
MAILER_ENCRYPTION=ssl
MAILER_FROM=Supla

# If you want to be notified about some server errors, set this
ADMIN_EMAIL=xxxxxxxxxxxxxxxxx.com.pl

# Where to store SUPLA Cloud's data
VOLUME_DATA=./var

# On which ports the SUPLA Cloud should listen (only if standalone mode)
#PORT_HTTP=80
#PORT_HTTPS=443

REQUIRE_REGULATIONS_ACCEPTANCE=false
REQUIRE_COOKIE_POLICY_ACCEPTANCE=false
BRUTE_FORCE_AUTH_PREVENTION_ENABLED=true
ACCOUNTS_REGISTRATION_ENABLED=true

# These options protect your application
DB_PASSWORD=uEzVtaCyd2UWxWBIccVccZzZa6PVqEjX
SECRET=z4s5ngZ9ukxTpjoiniJeHKvrjIOywwid

COMPOSE_PROJECT_NAME=supla
COMPOSE_PATH_SEPARATOR=:
#COMPOSE_FILE=docker-compose.yml:docker-compose.standalone.yml:docker-compose.arm32v7.yml
COMPOSE_FILE=docker-compose.yml:docker-compose.proxy.yml:docker-compose.arm32v7.yml
Pogodynka >>
effendi
Posts: 165
Joined: Wed Apr 26, 2017 9:36 am

Post

po wykasowaniu numeru portu po nazwie domeny, komunikat ze strony zmieni się na
502 Bad Gateway
... a po przeładowaniu kontenerów >>> DZIAŁA!!
Pogodynka >>
User avatar
lesny8
Posts: 2851
Joined: Mon Dec 11, 2017 9:43 pm

Post

Możesz usunąć ten port 443 bo jest on standardowy dla https i bez tego powinno działać.
Po każdej zmianie w .env trzeba zrobić restart kontenerów supli i po wstaniu odczekać chwilę.
Czekam na kolejne Supla Offline Party 👍
karnasw
Posts: 197
Joined: Fri Oct 02, 2020 10:22 am

Post

Czy proxy można też zrobić w samej lokalnej sieci czy to się tyczy tylko dostępu z zewnątrz? Póki co nie mam adresu zewnętrznego, a nie przepadam za ostrzeżeniami o certyfikacie? Chodzi mi o ustawienie domeny lokalnie w sieci.
marik_te
Posts: 31
Joined: Thu May 13, 2021 2:50 pm

Post

Mam problem z postawieniem supli w trybie proxy. W standalone dziala mi juz z rok, ale przyszedl czas pojsc dalej.
Utknalem na punkcie 2 instrukcji, czyli

Clone and run the docker-compose-letsencrypt-nginx-proxy-companion according to the instructions on their site. Clone it outside the supla-docker directory. An example desired directory structure is as follows:

/some/apps/directory/
supla-docker/
docker-compose-letsencrypt-nginx-proxy-companion/

Postepujac zgodnie z instrukcja mam niestety blad przy pierwszym uruchomieniu proxy poleceniem fresh_start.sh

Dodam ze odpalam to na ubuntu.
W jakim konkretnie ma byc wrzucony proxy?

Return to “supla-docker”