[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

User avatar
klimasstudio
Posts: 1135
Joined: Wed Aug 28, 2019 9:35 pm
Location: localhost

Post

Na którym etapie masz problem ? Bo samo napisanie mi nie działa nie pomaga. Najłatwiej napisać że coś nie działa jak się nie czyta komunikatów. Instalacja rzeczy na linuxie to nie jest klepanie kopiuj, wklej... trzeba czytać na bieżąco co się pojawia i szukać podpowiedzi w internecie lub forum.

Także proszę pokaż na jakim etapie utknąłeś i co Ci nie działa?
Więc chodź OSUPLUJE Ci dom :mrgreen:

Druk 3D - > https://klimastech.eu.org/druk-3d
Jkogut
Posts: 7
Joined: Tue May 21, 2024 1:31 pm

Post

Oczywiście rozumiem, że tzeba podać konkretnie co nie działa :-)
Więc: RPI 5 z systemem Raspberry Pi OS with desktop 32-bit, kernel 6.6
Instalacja w oparciu o https://github.com/SUPLA/supla-docker w trybie standalone kończy się pomyślnie (po zamianie w lini 23 pliku supla.sh na
elif [ "$(expr substr $(uname -m) 1 3)" == "aar" ]; then
)

Natomiast instalacja wg opisu https://klimastech.eu.org/supla-docker- ... r-compose/ przy próbie utworzenia stacka supla-docker zwraca komunikat:
failed to deploy a stack: supla-cloud Pulling supla-server Pulling supla-db Pulling 4feff9b88735 Pulling fs layer 71170e9d0bac Pulling fs layer 6536bea6d583 Pulling fs layer 1c1abff35097 Pulling fs layer 2f2a6f3da0fb Pulling fs layer 39d2b2c0b0f2 Pulling fs layer b159800ec0b2 Pulling fs layer 1c1abff35097 Waiting 2f2a6f3da0fb Waiting 39d2b2c0b0f2 Waiting b159800ec0b2 Waiting supla-cloud Error no matching manifest for linux/arm/v8 in the manifest list entries
-----------------------------------------------------------------
ZSTI w Mszanie Dolnej
Pracownia automatyki budynkowej i IoT
User avatar
klimasstudio
Posts: 1135
Joined: Wed Aug 28, 2019 9:35 pm
Location: localhost

Post

Natomiast instalacja wg opisu https://klimastech.eu.org/supla-docker- ... r-compose/ przy próbie utworzenia stacka supla-docker zwraca komunikat:
failed to deploy a stack: supla-cloud Pulling supla-server Pulling supla-db Pulling 4feff9b88735 Pulling fs layer 71170e9d0bac Pulling fs layer 6536bea6d583 Pulling fs layer 1c1abff35097 Pulling fs layer 2f2a6f3da0fb Pulling fs layer 39d2b2c0b0f2 Pulling fs layer b159800ec0b2 Pulling fs layer 1c1abff35097 Waiting 2f2a6f3da0fb Waiting 39d2b2c0b0f2 Waiting b159800ec0b2 Waiting supla-cloud Error no matching manifest for linux/arm/v8 in the manifest list entries
Czyli na ślepo klepane...
IMAGE_VERSION=latest – Domyślny obraz dla komputerów z procesorem x86 lub x64 wpisujemy latest, jeżeli używamy Raspberry Pi wpisujemy „arm32v7„
Sam error wskazuje co jest przyczyną ;)
Więc chodź OSUPLUJE Ci dom :mrgreen:

Druk 3D - > https://klimastech.eu.org/druk-3d
Jkogut
Posts: 7
Joined: Tue May 21, 2024 1:31 pm

Post

IMAGE_VERSION=arm32v7
Tak wlasnie mam wpisane w Environment variables - staralem sie dokladnie czytac "ze zrozumieniem" Twoj poradnik
Mimo to dostaje komunikat:
Waiting no matching manifest for linux/arm/v8 in the manifest list entries
-----------------------------------------------------------------
ZSTI w Mszanie Dolnej
Pracownia automatyki budynkowej i IoT
User avatar
lesny8
Posts: 2852
Joined: Mon Dec 11, 2017 9:43 pm

Post

Pokaż co Ci daje

Code: Select all

uname -a
Czekam na kolejne Supla Offline Party 👍
User avatar
klimasstudio
Posts: 1135
Joined: Wed Aug 28, 2019 9:35 pm
Location: localhost

Post

Próbujesz instalować wersje niezgodną z Twoją architekturą.
Więc chodź OSUPLUJE Ci dom :mrgreen:

Druk 3D - > https://klimastech.eu.org/druk-3d
Jkogut
Posts: 7
Joined: Tue May 21, 2024 1:31 pm

Post

Code: Select all

Linux raspberrypi 6.6.20+rpt-rpi-v8 #1 SMP PREEMPT Debian 1:6.6.20-1+rpt1 (2024-03-07) aarch64 GNU/Linux
A OS to:
Raspberry Pi OS with desktop
Release date: March 15th 2024
System: 32-bit
Kernel version: 6.6
Debian version: 12 (bookworm)
-----------------------------------------------------------------
ZSTI w Mszanie Dolnej
Pracownia automatyki budynkowej i IoT
Jkogut
Posts: 7
Joined: Tue May 21, 2024 1:31 pm

Post

klimasstudio wrote: Fri May 24, 2024 10:52 am Próbujesz instalować wersje niezgodną z Twoją architekturą.
A jaka powinieniem wybrac?

A jednak z arm32v7 sie udalo (wg opisu z githuba). Natomiast nadal nie udalo mi sie uruchomic kontenetow supli wg opisu https://klimastech.eu.org/supla-docker- ... r-compose/
mimo wybrania:
IMAGE_VERSION=arm32v7
You do not have the required permissions to view the files attached to this post.
-----------------------------------------------------------------
ZSTI w Mszanie Dolnej
Pracownia automatyki budynkowej i IoT
User avatar
klimasstudio
Posts: 1135
Joined: Wed Aug 28, 2019 9:35 pm
Location: localhost

Post

Nie udało Ci sie bo... ? Jaki błąd problem ?
Więc chodź OSUPLUJE Ci dom :mrgreen:

Druk 3D - > https://klimastech.eu.org/druk-3d
Jkogut
Posts: 7
Joined: Tue May 21, 2024 1:31 pm

Post

Opisałem ten błąd to kilka postów wyżej -> viewtopic.php?p=180261#p180261

Mimo iż wybrałem
IMAGE_VERSION=arm32v7
przy tworzeniu stacka dostaje błąd:
Waiting no matching manifest for linux/arm/v8 in the manifest list entries
Wszystko chodzi OK (patrz zrzuty ekranowe w poprzednim poście) przy instalacji z githuba, a tam jest nieco inny inny obraz bazy danych niż u Ciebie w opisie.
Zaznaczam, że chodzi o Raspberry PI 5 i kernel 6.6 z 15.03.2024.
Stąd moje pytanie: Czy ktoś z Was ma doświadczenia z instalacji wg @klimasstudio na RPI 5 ???
-----------------------------------------------------------------
ZSTI w Mszanie Dolnej
Pracownia automatyki budynkowej i IoT

Return to “FAQ / Jak to zrobić”