ESP8266 Primary GUI

Rafaello
Posty: 74
Rejestracja: ndz maja 29, 2016 1:34 pm

pn cze 03, 2019 7:35 pm

Chyba namierzyłem ostatnią wersję Primary GUI, zaktualizowałem zgodnie ze wskazówkami, ładnie się kompiluje oraz wgrywa, po odpaleniu modułu i połączeniu się z MODUL SUPLA, przy próbie zalogowaniu się na 192.168.4.1, moduł się resetuje i ponownie wraca do trybu konfiguracji, i tak w kółko, ech jak nie urok to sraczka :)

pzdr
RW
cino111
Posty: 710
Rejestracja: pn maja 07, 2018 8:00 pm

pn cze 03, 2019 7:38 pm

U mnie właśnie to samo nie wiem dlaczego. Wcześniej normalnie mi się kompilowalo.
Awatar użytkownika
wojtas567
Posty: 1891
Rejestracja: ndz kwie 03, 2016 7:16 pm
Lokalizacja: Olsztyn

pn cze 03, 2019 7:42 pm

U mnie na arduino 1.8.5, menager płytek 2.4.2, no i suplaDevice - espablo kompiluje się OK.
Pozdrawiam
Wojtek
Rafaello
Posty: 74
Rejestracja: ndz maja 29, 2016 1:34 pm

czw cze 06, 2019 5:41 pm

cino111 pisze:
pn cze 03, 2019 7:38 pm
U mnie właśnie to samo nie wiem dlaczego. Wcześniej normalnie mi się kompilowalo.
Udało się coś skompilować? :)

pzdr
RW
vajera
Posty: 179
Rejestracja: śr paź 31, 2018 7:58 am

czw cze 06, 2019 6:47 pm

Pytanie, którą wersję SuplaDevice masz w katologu /Users/<username>/Documents/Arduino/libraries/? Czy jest to wersja od Espablo czy "oryginalna"?
U mnie biblioteka od Espablo powodowała problemy z innymi kompilacjami, więc w końcu zmieniłem jej nazwę na SuplaDevicePGUI.
Rafaello
Posty: 74
Rejestracja: ndz maja 29, 2016 1:34 pm

czw cze 06, 2019 7:32 pm

Może ktoś udostępnić Primary_GUI łącznie z SuplaDevice oraz TrueRandom i innymi wymaganymi bibliotekami niestandardowymi, które im się poprawnie kompiluje.

Ktoś co jakiś czas coś udostępni ale najczęściej okazuje się to niekompletne.

pzdr
RW
Awatar użytkownika
uchnast.michal
Posty: 206
Rejestracja: wt cze 04, 2019 11:37 am
Lokalizacja: Czeladź
Kontaktowanie:

sob lip 13, 2019 4:44 pm

Rafaello pisze:
czw cze 06, 2019 7:32 pm
Może ktoś udostępnić Primary_GUI łącznie z SuplaDevice oraz TrueRandom i innymi wymaganymi bibliotekami niestandardowymi, które im się poprawnie kompiluje.

Ktoś co jakiś czas coś udostępni ale najczęściej okazuje się to niekompletne.

pzdr
RW
Podpisuję się pod prośbą, niezmiennie problem z kompilacją :(
krycha88
Posty: 645
Rejestracja: pt lis 16, 2018 7:25 am

sob lip 13, 2019 6:52 pm

uchnast.michal pisze:
sob lip 13, 2019 4:44 pm
Rafaello pisze:
czw cze 06, 2019 7:32 pm
Może ktoś udostępnić Primary_GUI łącznie z SuplaDevice oraz TrueRandom i innymi wymaganymi bibliotekami niestandardowymi, które im się poprawnie kompiluje.

Ktoś co jakiś czas coś udostępni ale najczęściej okazuje się to niekompletne.

pzdr
RW
Podpisuję się pod prośbą, niezmiennie problem z kompilacją :(
To może wrzucie logi z kompilacji będzie łatwiej pomóc :)
Awatar użytkownika
uchnast.michal
Posty: 206
Rejestracja: wt cze 04, 2019 11:37 am
Lokalizacja: Czeladź
Kontaktowanie:

ndz lip 14, 2019 7:38 am

krystianmen pisze:
sob lip 13, 2019 6:52 pm

To może wrzucie logi z kompilacji będzie łatwiej pomóc :)
Po co logi jeżeli proszę o biblioteki, których nie moge nigdzie znaleźć? Co do błędów kompilacji to koledzy w innym wątku juz mi pomagają na podstawie umieszczonych logów.
Awatar użytkownika
fracz
Posty: 1781
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

pn lip 15, 2019 5:31 pm

Próbujemy uporządkować soft tworzony w tym wątku i dołączyć go do oficjalnego repo. Po nałożeniu kodu z pierwszego posta w tym wątku na aktualną wersję "oficjalną" mamy takie zmiany: https://github.com/fracz/arduino/commit ... e6fb0401ec

Poza tym że wersja z tego wątku nie zawiera nowych typów czujników (co jest wynikiem "kopiuj wklej" przeze mnie) - nie widze tam nigdzie tego nowego "GUI". Czy ono zostało zaimplemenotwane poza biblioteką SuplaDevice? Jeśli tak to dlaczego?
ODPOWIEDZ