Wgrywanie supli do chińskiego wemosa

User avatar
YoMan
Posts: 2340
Joined: Thu Apr 30, 2020 5:18 pm
Location: Częstochowa

Post

zbysek88 wrote: Sun May 12, 2024 7:34 pm
YoMan wrote: Sun May 12, 2024 6:51 pm
zbysek88 wrote: Sun May 12, 2024 5:33 pm Cześć,

mam problem z wgraniem binarki z gui-generic do wemosa D1. System windows wykrywa mi go jako USB-SERIAL CH340 (COM4), wpisuje te ustawienia, które są w poście powyżej i niestety nic się nie dzieje. Próbowałem także flash download tools i tutaj nawet przy próbie wyczyszczenia pamięci klikając "erase" program zwraca błąd "com fail". Czy ten moduł wprowadza się w jakiś inny sposób w tryb programowania? Próbowałem podłączać go po prostu pod USB, później podłączałem go trzymając przycisk "reset" i nic to nie dało.
Nie powinieneś nic robić, on sam wejdzie w tryb flashowania. Gui mozesz tez wgrac przez strone, masz opcje od razu po wygenerowaniu.
Użyj porządnego kabla USB, wiele przewodów nie działa bo są np. tylko zasilające albo w inny sposób okrojone. Przypuszczam że tutaj leży twój problem
Próbowałem na dwóch kablach i cały czas to samo. Menedżer urządzeń wykrywa mi moduł CH340. Po wygenerowaniu pliku na stronie gui-generic też próbowałem wgrać plik lecz z takim samym mizernym skutkiem. Wemos uszkodzony?
czy wcześniej na którymś z tych przewodów udało się flashować? Czy daj jakieś komunikaty przez serial?
Możliwe również że Wemos uszkodzony. Nie mając możliwości porównania ciężko coś mądrzejszego napisać.
YoMan
________________________________________
Wziąłem udział w Supla Offline Party 2023 ;)

Return to “Pomoc”