Funkcja deep sleep

krycha88
Posts: 5243
Joined: Fri Nov 16, 2018 7:25 am

Post

edm wrote: Tue Jan 30, 2024 6:45 pm Jasne 🙂. W końcu to jest Twoja dobra wola.
Z ciekawości napisz jaśniej jest błąd czy go nie ma?.
Z Twojej odpowiedzi wnioskuję że jest problem ale po stronie supla cloud.
Jeżeli chodzi o korekty to teraz wykorzystuję tylko i wyłączenie klocki z biblioteki. Nie wiem gdzie jest problem.
https://gui-generic-builder.supla.io/
User avatar
Robert Błaszczak
Posts: 4114
Joined: Sat Dec 22, 2018 8:55 pm
Location: Zielona Góra

Post

edm wrote: Tue Jan 30, 2024 4:35 pm
Robert Błaszczak wrote: Sun Jan 28, 2024 4:15 pm I jest OK 👍. Korekta wprowadzana w Cloud nie powoduje żadnych problemów.
Witam Panowie.
Chyba jest coś nie tak z tą korektą z poziomu supla cloud. Poniżej link do filmu.
Krótki opis sytuacji. Soft wygenerowany na nowo i wgrany do BoneIO z poziomu Gui generic z opcją Erase.
Na początku wartość temperatury i wilgotności jest taka sama, poprawna w supla cloud jak i z poziomu web gui sterownika. Wynosi 21,77 stopni i 66,55 %. Po czym z poziomu supla cloud robię korektę na plus 10 temperatury i wilgotności, czekam jak się synchronizuje, zapisze.
Po tym robię restart BoneIO i w web gui sterownika widać że temperatura oraz wilgotność wzrosła o 10, czyli niby dobrze.
Ale w supla cloud samoczynnie wzrosło ponownie o kolejne 10 czyli razem 20. Wpisując różne korekty nawet na minus - 10 nie da się powrócić do stanu z przed korekty. Żeby temperatura w supla cloud i web gui sterownika wynosiła poprawnie około 21,77 stopni i 66,55 %.
Usuwanie sterownika z supla cloud i ponowna rejestracja nic nie pomaga.
https://drive.google.com/file/d/1WXxtTW ... NGpiU/view
Nie mogę u siebie tego powtórzyć. Nagrałem filmik: https://drive.google.com/file/d/1qBwC5C ... xAmAa/view
I jeszcze jeden z widokiem WEB-GUI: https://drive.google.com/file/d/1AnHfuc ... qZbAn/view
Pozdrawiam
Robert Błaszczak


Moja prywatna strona: www.blaszczak.pl
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

edm wrote: Tue Jan 30, 2024 4:35 pm
Robert Błaszczak wrote: Sun Jan 28, 2024 4:15 pm I jest OK 👍. Korekta wprowadzana w Cloud nie powoduje żadnych problemów.
Witam Panowie.
Chyba jest coś nie tak z tą korektą z poziomu supla cloud. Poniżej link do filmu.
Krótki opis sytuacji. Soft wygenerowany na nowo i wgrany do BoneIO z poziomu Gui generic z opcją Erase.
Na początku wartość temperatury i wilgotności jest taka sama, poprawna w supla cloud jak i z poziomu web gui sterownika. Wynosi 21,77 stopni i 66,55 %. Po czym z poziomu supla cloud robię korektę na plus 10 temperatury i wilgotności, czekam jak się synchronizuje, zapisze.
Po tym robię restart BoneIO i w web gui sterownika widać że temperatura oraz wilgotność wzrosła o 10, czyli niby dobrze.
Ale w supla cloud samoczynnie wzrosło ponownie o kolejne 10 czyli razem 20. Wpisując różne korekty nawet na minus - 10 nie da się powrócić do stanu z przed korekty. Żeby temperatura w supla cloud i web gui sterownika wynosiła poprawnie około 21,77 stopni i 66,55 %.
Usuwanie sterownika z supla cloud i ponowna rejestracja nic nie pomaga.
https://drive.google.com/file/d/1WXxtTW ... NGpiU/view
Prywatny serwer? Masz najnowszą wersję?
Widzimy się na Supla Offline Party vol. 2 :!:
edm
Posts: 451
Joined: Mon Jan 15, 2018 6:18 pm

Post

klew wrote: Wed Jan 31, 2024 7:22 am Prywatny serwer? Masz najnowszą wersję?
Nie. Oficjalny svr9.
Dzisiaj wieczorem zrobię jeszcze 1 test. Nagram tylko ekran z supla cloud, ustawię korekty na wartość 10 zapiszę i po tym wyłączę z prądu i włączę BoneIO - którego sercem jest WT32-ETH01. Dotychczas robiłem restart sterownika z poziomu web gui urządzenia. Nie sądzę żeby to była jakaś różnica ale sprawdzić nie zaszkodzi.
Wziąłem udział w Supla Offline Party 2023 :D
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

edm wrote: Wed Jan 31, 2024 8:08 am
klew wrote: Wed Jan 31, 2024 7:22 am Prywatny serwer? Masz najnowszą wersję?
Nie. Oficjalny svr9.
Dzisiaj wieczorem zrobię jeszcze 1 test. Nagram tylko ekran z supla cloud, ustawię korekty na wartość 10 zapiszę i po tym wyłączę z prądu i włączę BoneIO - którego sercem jest WT32-ETH01. Dotychczas robiłem restart sterownika z poziomu web gui urządzenia. Nie sądzę żeby to była jakaś różnica ale sprawdzić nie zaszkodzi.
Możesz zebrać logi z urządzenia? Ważne aby były od samego początku do około 30 s po rejestracji w Cloud.
Widzimy się na Supla Offline Party vol. 2 :!:
User avatar
Robert Błaszczak
Posts: 4114
Joined: Sat Dec 22, 2018 8:55 pm
Location: Zielona Góra

Post

@edm, sprawdź też jak to się zachowuje tylko gdy w konfiguracji / firmware wybierzesz 1 czujnik temperatury i wilgotności. Ja testowałem na SHT31.
Pozdrawiam
Robert Błaszczak


Moja prywatna strona: www.blaszczak.pl
edm
Posts: 451
Joined: Mon Jan 15, 2018 6:18 pm

Post

klew wrote: Wed Jan 31, 2024 8:22 am Możesz zebrać logi z urządzenia? Ważne aby były od samego początku do około 30 s po rejestracji w Cloud.
Ok. Podpowiedz jakim programem to zrobić?.
Robiłem takie rzeczy jak miałem problemy z routerem na openwrt. Na ESP jeszcze nie próbowałem.
Wziąłem udział w Supla Offline Party 2023 :D
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

edm wrote: Wed Jan 31, 2024 9:02 am
klew wrote: Wed Jan 31, 2024 8:22 am Możesz zebrać logi z urządzenia? Ważne aby były od samego początku do około 30 s po rejestracji w Cloud.
Ok. Podpowiedz jakim programem to zrobić?.
Robiłem takie rzeczy jak miałem problemy z routerem na openwrt. Na ESP jeszcze nie próbowałem.
Putty, serial monitor z Arduino IDE, itd.
Widzimy się na Supla Offline Party vol. 2 :!:
edm
Posts: 451
Joined: Mon Jan 15, 2018 6:18 pm

Post

1. Film. W ustawieniach web gui wybrane 1 x BME280 0x76, korekta o 10 i OFF i ON sterownik i nic więcej. Widać ja po restarcie temperatura i wilgotność w supla cloud wzrasta o kolejną wartość 10, łącznie 20. https://drive.google.com/file/d/1a1buGa ... drive_link

2. Film. W ustawieniach web gui wybrane 2 x BME280 0x76 i 0x77, korekta tylko 1 BME280 o 10 i OFF i ON sterownik i nic więcej. Widać ja po restarcie temperatura i wilgotność w supla cloud wzrasta o kolejną wartość 10, łącznie 20. https://drive.google.com/file/d/1eKm2yj ... drive_link

Log 1. Pod koniec z poziomu supla cloud zrobiłem korektę o wartość 10 temperatury i wilgotności.
Log 2. Po korekcie opisanej w Log 1, wyłączyłem z prądu sterownik i podłączyłem ponownie. Widać w tym logu

Code: Select all

Channel[60] temperature correction 10.000000
Channel[60] humidity correction 10.000000
....
Channel(60) value changed to temp(32.290001), humi(84.555664)
Ale w rzeczywistości w supla cloud pokazało się o kolejne 10 więcej czyli temp(42.290001), humi(94.555664).
Czary ;)
You do not have the required permissions to view the files attached to this post.
Wziąłem udział w Supla Offline Party 2023 :D
krycha88
Posts: 5243
Joined: Fri Nov 16, 2018 7:25 am

Post

Problem pewnie powyżej 60 kanału na urządzenie :lol:
https://gui-generic-builder.supla.io/

Return to “GUI Generic”