boneIO - ciekawy sterownik

edm
Posts: 448
Joined: Mon Jan 15, 2018 6:18 pm

Post

krycha88 wrote: Fri Jan 12, 2024 9:28 am A to czasami buzzer nie hałasuje? Może coś użyłeś na GPIO2? Wyłączyłem buzzera na stałe.
Po tym jak BoneIO wysypał mi się po aktualizacji z poziomu GG (brak z nim jakiejkolwiek komunikacji), mam go na biurku i nic do niego nie jest podłączone. Wygenerowałem jeszcze raz GG w możliwie najbardziej uproszczonej konfiguracji wgrałem przez kabel USB z poziomu instalatora GG i dźwięki dość głośne są takie jak opisałem w poście powyżej.
Na próbę wgrałem inny soft (bez obsługi czujników temperatury itp., zmiany stanu sterowania przekaźnikami) raczej też Twój ale nie GG i tutaj wszystko w porządku, cisza.
Wziąłem udział w Supla Offline Party 2023 :D
krycha88
Posts: 5231
Joined: Fri Nov 16, 2018 7:25 am

Post

Ale wygrałeś najnowsza wersję? Gdzie wyłączyłem buzzer?
https://gui-generic-builder.supla.io/
edm
Posts: 448
Joined: Mon Jan 15, 2018 6:18 pm

Post

krycha88 wrote: Fri Jan 12, 2024 10:15 am Ale wygrałeś najnowsza wersję? Gdzie wyłączyłem buzzer?
A kiedy ona powstała, jeśli wczoraj lub dzisiaj?, to tej nie wgrywałem. Wiadomo co powoduje wydawanie dźwięku buzzera?, jest to bezpieczne dla modułu?.
Wziąłem udział w Supla Offline Party 2023 :D
krycha88
Posts: 5231
Joined: Fri Nov 16, 2018 7:25 am

Post

edm wrote: Fri Jan 12, 2024 10:30 am A kiedy ona powstała, jeśli wczoraj lub dzisiaj?, to tej nie wgrywałem. Wiadomo co powoduje wydawanie dźwięku buzzera?, jest to bezpieczne dla modułu?.
Dzisiaj wrzuciłem poprawkę więc ciężko ją w wczorajszych buildach :) Nie wiem, co się zmieniło, że buzzer zachowuje się inaczej. Bezpieczna wersja to była ta dedykowana dla tego urządzenia :P
https://gui-generic-builder.supla.io/
edm
Posts: 448
Joined: Mon Jan 15, 2018 6:18 pm

Post

krycha88 wrote: Fri Jan 12, 2024 11:58 am Dzisiaj wrzuciłem poprawkę więc ciężko ją w wczorajszych buildach :) Nie wiem, co się zmieniło, że buzzer zachowuje się inaczej. Bezpieczna wersja to była ta dedykowana dla tego urządzenia :P
Ok po południu wgram i zobaczę.
A jest jakaś szansa pozyskanie poprzedniej wersji softu mowa o software z SuplaDevice GG v7.4.25. Masz jakąś kopię lub Link do aktualizacji modułu, tej starszej wersji.

Na drugim module BoneIO mam to starsze Firmware: SuplaDevice GG v7.4.25. Czy może za pomocą Narzędzia zapisz konfigurację jest możliwe wygenerowanie tej starszej wersji. Czy to tylko bieżący zapis ustawień danego modułu.
Wziąłem udział w Supla Offline Party 2023 :D
krycha88
Posts: 5231
Joined: Fri Nov 16, 2018 7:25 am

Post

Nie posiadam.
https://gui-generic-builder.supla.io/
edm
Posts: 448
Joined: Mon Jan 15, 2018 6:18 pm

Post

krycha88 wrote: Fri Jan 12, 2024 11:58 am Dzisiaj wrzuciłem poprawkę więc ciężko ją w wczorajszych buildach :) Nie wiem, co się zmieniło, że buzzer zachowuje się inaczej. Bezpieczna wersja to była ta dedykowana dla tego urządzenia :P
Zainstalowałem dzisiejszą wersję po poprawkach. Sterownik BoneIO wydaje dźwięki jak na poprzedniej wersji GUI-Generic: v7.9.6; Builder: v6.0.0. Dodam że kaloryfer na którym leży BoneIO jest zimny, żeby nie sugerować przegrzania sterownika :D.
Tu jest film https://drive.google.com/file/d/1mETh7H ... sp=sharing zawierający fragment końcowy wgrywania dzisiejszej wersji softu gdzie wdać, słychać że zaraz po zakończeniu wgrywania pojawia się pikanie.

Natomiast tu jest film https://drive.google.com/file/d/1C7mLcn ... sp=sharing po skonfigurowaniu połączenia WiFi, serwera supla, email itd. Na potrzeby zaprezentowania tego wyłączyłem i włączyłem zasilanie BoneIO. Pikanie przerywane zmienia się w ciągłe.
Co prawda na filmie nie słychać wszystkich dźwięków i ich częstotliwości czasowych które były zaraz po skonfigurowaniu połączenia WiFi, serwera supla, email itd., ponieważ tym samym telefonem konfigurowałem sterownik i po tym nagrywałem wideo. Lecz efekt był taki że trochę popiszczało nie koniecznie w równych odstępach jak w pierwszym filmie, po czym po ustanowieniu połączenia z supla cloud zaczęło piszczeć dźwiękiem ciągłym.

Można by przypuszczać że to usterka sterownika, ale jak wgrywam "dedykowane firmware" boneIO_24x16A_MCP za pomocą ESPHome-Flasher-1.4.0-Windows-x64 to już na samym początku wgrywania piszczenie ustaje całkowicie, soft się wgrywa poprawnie i można korzystać ze sterownika. Nic nie piszczy.

Mam 2 szt. BoneIO w razie czego mogę na 2 również zrobić test, żeby wykluczyć usterkę urządzenia. Lecz dziwne jest to że ten 1 BoneIO działa poprawnie z dedykowanym softem.
Last edited by edm on Sat Jan 13, 2024 7:53 am, edited 2 times in total.
Wziąłem udział w Supla Offline Party 2023 :D
krycha88
Posts: 5231
Joined: Fri Nov 16, 2018 7:25 am

Post

Wygląda jakby pod led konfiguracyjny ustawił się gpio2. Weź zobacz w opcjach co masz ustawione dla LED konfiguracyjnego
https://gui-generic-builder.supla.io/
edm
Posts: 448
Joined: Mon Jan 15, 2018 6:18 pm

Post

krycha88 wrote: Fri Jan 12, 2024 7:40 pm Wygląda jakby pod led konfiguracyjny ustawił się gpio2. Weź zobacz w opcjach co masz ustawione dla LED konfiguracyjnego
Chyba jest jak piszesz. Lecz musi to wynikać z softu GG bo ja tam nic nie zmieniałem. Jakie GPIO powinno tam być?
You do not have the required permissions to view the files attached to this post.
Wziąłem udział w Supla Offline Party 2023 :D
User avatar
Robert Błaszczak
Posts: 4091
Joined: Sat Dec 22, 2018 8:55 pm
Location: Zielona Góra

Post

Na 100% to jest ten problem. Od jakiegoś czasu na prośbę Forumowiczów (w tym moją) jest w GUI-Generic domyślnie ustawione GPIO dla LED.
Miało to być ułatwienie dla wgrywających soft na Wemosy, które mają wbudowany LED właśnie na GPIO2.
Pozdrawiam
Robert Błaszczak


Moja prywatna strona: www.blaszczak.pl

Return to “Projekty użytkowników”