Współpraca po mqtt

pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

Załączam resztę configa aby wszystko było jasne:
You do not have the required permissions to view the files attached to this post.
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

Sprawdziłem to u siebie i opóźnienie jest (bo musi być), ale jest krócej niż u Ciebie. Na oko jest poniżej 1 s.
Tutaj filmik:
https://www.youtube.com/shorts/B8NPxDV0ZK0

Na przycisku monostabilnym z czasem detekcji wieloklików 0,3 s, opóźnienie generowane przez RNW-01 to 0,3-0,4 s od momentu zwolnienia przycisku (dodatkowe 20-30 ms jest doliczane na odfiltrowanie zakłóceń i drgań styków). Czasem widzę u Ciebie, że lekko przytrzymujesz przycisk, co może wydłużać ten czas. Natomiast u Ciebie mimo wszystko czas reakcji jest za długi.
Przyczyny szukałbym:
1. W sieci Wi-Fi (możesz sprawdzić jak działa ping z maszyny na której stoi broker mqtt do RNW-01)
2. Obciążenie maszyny z brokerem MQTT (czasem do tego celu używane są malinki i inne mini-komputery, które wcale demonami szybkości nie są)
3. Opóźnieniem między brokerem MQTT a lokalnym komputerem z MQTT Explorerem.

Aby wykluczyć/potwierdzić powyższe problemy, możesz spróbować postawić sobie broker na innym kompie i spróbować podłączyć się do niego.

Z strony RNW-01 możesz zrobić jeszcze jedną rzecz. Jeśli nie planujesz ustawiać żadnych dodatkowych reakcji na wielokliki i chcesz mieć tylko jedną reakcję na każdym przycisku, to w trybie konfiguracyjnym modułu, zmień przyciski na bistabilne. One wtedy mają dwa zdarzenia, które są publikowane bez żadnych opóźnień - button_turn_on i button_turn_off.
Tutaj filmik na którym widać działanie tego ustawienia:
https://www.youtube.com/shorts/ZBn278vZB_k
Widzimy się na Supla Offline Party vol. 2 :!:
pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

Z tym ustawieniem na bistabilne to bardzo dobry trop i pomysł. Powinno przyspieszyć a poza tym na pewno zobaczę jaki jest czas reakcji pozostałych elementów sieci / MQTT na sygnał z RNW-01. Dam znać jak wyniki testów.
pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

Za co odpowiedzialny jest ten parametr?
IN1234 Config.jpg
You do not have the required permissions to view the files attached to this post.
pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

No i test wykonałem. Po z imanie konfiguracji na bistabline RNW wysyła informacje po MQTT natychmiast. Opóźnienie jest trudne do zauważenia, a zatem wydajność brokera MQTT i obciążenie WIFI czy siła sygnału nie mają tu żadnego związku. Zauważyłem jeszcze jedną dziwną sprawę: po skonfigurowaniu w tryb bistabilny RNW wysyła po MQTT trzy informacje (turn_on, single, turn_off z czego czasami single dwukrotnie) zamiast spodziewanych dwóch (turn_on, turn_off).
Czy istnieje możliwość przyspieszenia działania RNW w trybie monostabilnym? Rozumiem, że musi on odczekać na ewentualne kolejne naciśnięcie, ale to chyba tyle, więc powinno to być opóźnienie ok. 0,4 sek a nie kilka sek.
User avatar
pzygmunt
Posts: 18590
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

pjasinsk wrote: Thu Sep 01, 2022 12:48 pm Za co odpowiedzialny jest ten parametr?
IN1234 Config.jpg
Możliwość przejścia w tryb konfiguracji z przycisku podłączonego pod wejścia 1-4
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

pjasinsk wrote: Mon Sep 05, 2022 6:31 am No i test wykonałem. Po z imanie konfiguracji na bistabline RNW wysyła informacje po MQTT natychmiast. Opóźnienie jest trudne do zauważenia, a zatem wydajność brokera MQTT i obciążenie WIFI czy siła sygnału nie mają tu żadnego związku. Zauważyłem jeszcze jedną dziwną sprawę: po skonfigurowaniu w tryb bistabilny RNW wysyła po MQTT trzy informacje (turn_on, single, turn_off z czego czasami single dwukrotnie) zamiast spodziewanych dwóch (turn_on, turn_off).
Czy istnieje możliwość przyspieszenia działania RNW w trybie monostabilnym? Rozumiem, że musi on odczekać na ewentualne kolejne naciśnięcie, ale to chyba tyle, więc powinno to być opóźnienie ok. 0,4 sek a nie kilka sek.
Przycisk ustawiony jako bistabilny wysyła turn_on po każdym załączeniu i turn_off po każdym rozłączeniu.
Urządzenie wysyła toggle_1x, 2x, 3x, 4x, 5x - zależnie od tego ile naliczyło przełączeń. Każda zmiana stanu to jedno przełączenie. Więc:
- wciśniecie, wyłączenie - to 2x.
- wyłączenie - 1x
- włączenie - 1x
- wyłączenie, włączenie, wyłączenie, włączenie - 4x
itp

Wysłanie odpowiedniego zdarzenia następuje po 0,3s od ostatniej zmieny stanu. Czyli np. ten ostatni przykład powyżej z 4x powinien wysłać cztery razy: turn off, turn on, a następnie toggle_4x (nie pamiętam dokładnie jak te zdarzenia z mqtt się nazywały).

Co do monostabilnego, to nie wiem za bardzo co można poprawić. Niestety nie potrafię zreprodukować tego opóźnienia widocznego u Ciebie.

Jeszcze mi przyszło do głowy, że może masz przyciski rozłączne? Tzn. one cały czas są załączone (przewodzą prąd), a wciśnięcie przerywa obwód?
Widzimy się na Supla Offline Party vol. 2 :!:
pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

niestety nie.
Przyciski są NO.

Z Twojej odpowiedzi rozumiem, że wysyłanie toggle przy konfiguracji Bistabilnej jest zjawiskiem normalnym.
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

pjasinsk wrote: Tue Sep 13, 2022 11:04 am niestety nie.
Przyciski są NO.

Z Twojej odpowiedzi rozumiem, że wysyłanie toggle przy konfiguracji Bistabilnej jest zjawiskiem normalnym.
Tak, toggle jest wysyłane zawsze po upłynięciu czasu zliczania przełączeń.
Widzimy się na Supla Offline Party vol. 2 :!:
pjasinsk
Posts: 15
Joined: Mon Jul 25, 2022 9:31 pm

Post

klew: też chciałbym mieć takie opóźnienie przy klikaniu jak u Ciebie na filmiku :) Czy możesz podesłać pełną konfigurację swojego RNW i napisać którą masz wersję firmware'u?

Return to “ZAMEL RNW-01”