ESP8266 Problem Blue LED Flash Slowly

Post Reply
CdrHacker
Posts: 7
Joined: Sun May 22, 2016 8:07 am

ESP8266 Problem Blue LED Flash Slowly

Post by CdrHacker » Sun May 22, 2016 8:17 am

Hey Guys i'm From Aus Love the project.
Been using Blynk for my garage door but with extra coding for feedback loop hated it found you guys.
Anyway i am using NodeMCU its a ESP8266 with built in FTDI and voltage step down great product.(find info here https://nodemcu.readthedocs.io/en/dev/)
I could flash fine then put in to config mode and upload SSID,Pass,server... i can see it on the network even, then after restarting the Blue led just flashes slower than when in config mode and it wont even go back into config mode so i can see status.

any ideas :?:
Thanks in Advance

jangolen
Posts: 16
Joined: Thu Apr 14, 2016 6:10 pm

Re: ESP8266 Problem Blue LED Flash Slowly

Post by jangolen » Mon May 23, 2016 6:27 am

Is it connect to you network after restart? Check it in your router.

Check server for correct server adress : not "srv", right - svr1.supla.org. ID and pass for Access Identifiers from your cloud.supla.org

User avatar
pzygmunt
Posts: 6238
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: ESP8266 Problem Blue LED Flash Slowly

Post by pzygmunt » Mon May 23, 2016 7:17 am

What do you see in the console?
Check button connection.
Attachments
cfgbutton.png
cfgbutton.png (9.11 KiB) Viewed 2417 times

CdrHacker
Posts: 7
Joined: Sun May 22, 2016 8:07 am

Re: ESP8266 Problem Blue LED Flash Slowly

Post by CdrHacker » Mon May 23, 2016 7:26 am

Yes it is connected to my network after restating however how do i get a console connection to it? also the button is not pressed

User avatar
pzygmunt
Posts: 6238
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: ESP8266 Problem Blue LED Flash Slowly

Post by pzygmunt » Mon May 23, 2016 7:30 am

Run Putty
http://www.putty.org/

Set connection type to "Serial"
Select serial port where is connected esp8266 module (via FTDI converter).
Set speed to 74880
Click Open

CdrHacker
Posts: 7
Joined: Sun May 22, 2016 8:07 am

Re: ESP8266 Problem Blue LED Flash Slowly

Post by CdrHacker » Sat May 28, 2016 4:29 am

WiFi Status: 5
client handshake start.
devconn_disconnect_cb

state: 5 -> 0 (0)
rm 0
del if0
usl
¢„*«P*V¡¡ET©«´¥T«ª«*¥u´U+UZªZªT¢¤«TQT¥QQ©©jPE*E*µuª¥…¢üZT¥(EŠª«ªQ*UEu¢…ªªÅQBªµ¨U¥¨®UP¡QüZT¥(UEŠª«ªQZªEu¢…ªªÅU(Bªµ(U©µuª©ÅZT¥(EŠª«ªQZªEªj*QZªÅªµ+Õ­…-+PUUP´TT
SDK ver: 1.5.0 compiled @ Nov 27 2015 13:37:51
phy ver: 484, pp ver: 9.5

Starting
CFG READ SUCCESS!
mode : sta(18:fe:34:d3:f4:8c)
add if0
f r0, WiFi Status: 1
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 8
cnt

connected with Steve, channel 6
dhcp client start...
ip:192.168.0.14,mask:255.255.255.0,gw:192.168.0.1
WiFi Status: 5
client handshake start.
devconn_disconnect_cb

state: 5 -> 0 (0)
rm 0
del if0
usl
¢„*«P*V¡¡ET©«´¥T«ª«*¥u´U+UZªZªT¢¤«TQT¥QQ©©jPE*E*µuª¥…¢üZT¥(EŠª«ªQ*UEu¢…ªªÅQBªµ¨U¥¨®UP¡QüZT¥(UEŠª«ªQZªEu¢…ªªÅU(Bªµ(U©µuª©ÅZT¥(EŠª«ªQZªEªj*QZªÅªµ+Õ­…-+PUUP´TT
SDK ver: 1.5.0 compiled @ Nov 27 2015 13:37:51
phy ver: 484, pp ver: 9.5

Starting
CFG READ SUCCESS!
mode : sta(18:fe:34:d3:f4:8c)
add if0
f r0, WiFi Status: 1
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 8
cnt

connected with Steve, channel 6
dhcp client start...
ip:192.168.0.14,mask:255.255.255.0,gw:192.168.0.1
WiFi Status: 5
client handshake start.
devconn_disconnect_cb

state: 5 -> 0 (0)
rm 0
del if0
usl
¢„*«P*V¡¡ET©«´¥T«ª«*¥u´U+UZªZªT¢¤«TQT¥QQ©©jPE*E*µuª¥…¢üZT¥(EŠª«ªQ*UEu¢…ªªÅQBªµ¨U¥¨®UP¡QüZT¥(UEŠª«ªQZªEu¢…ªªÅU(Bªµ(U©µuª©ÅZT¥(EŠª«ªQZªEªj*QZªÅªµ+Õ­…-+PUUP´TT
SDK ver: 1.5.0 compiled @ Nov 27 2015 13:37:51
phy ver: 484, pp ver: 9.5

Starting
CFG READ SUCCESS!
mode : sta(18:fe:34:d3:f4:8c)
add if0
f r0, WiFi Status: 1
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 8
cnt

connected with Steve, channel 6
dhcp client start...
ip:192.168.0.14,mask:255.255.255.0,gw:192.168.0.1
WiFi Status: 5
client handshake start.
devconn_disconnect_cb

state: 5 -> 0 (0)
rm 0
del if0
usl
¢„*«P*V¡¡ET©«´¥T«ª«*¥u´U+UZªZªT¢¤«TQT¥QQ©©jPE*E*µuª¥…¢üZT¥(EŠª«ªQ*UEu¢…ªªÅQBªµ¨U¥¨®UP¡QüZT¥(UEŠª«ªQZªEu¢…ªªÅU(Bªµ(U©µuª©ÅZT¥(EŠª«ªQZªEªj*QZªÅªµ+Õ­…-+PUUP´TT
SDK ver: 1.5.0 compiled @ Nov 27 2015 13:37:51
phy ver: 484, pp ver: 9.5

Starting
CFG READ SUCCESS!
mode : sta(18:fe:34:d3:f4:8c)
add if0
f r0, WiFi Status: 1
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 8
cnt

connected with Steve, channel 6
dhcp client start...
ip:192.168.0.14,mask:255.255.255.0,gw:192.168.0.1
WiFi Status: 5
client handshake start.
devconn_disconnect_cb



Just keeps repeating this.

User avatar
pzygmunt
Posts: 6238
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: ESP8266 Problem Blue LED Flash Slowly

Post by pzygmunt » Sat May 28, 2016 7:26 am

For some reasons ESP lose estabilished connection with your wifi network. when it happen Supla software perfofm ESP restart so you don't have enought time to hold the button pressed. Turn off your WiFi network for a moment and then press the button.

User avatar
pzygmunt
Posts: 6238
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: ESP8266 Problem Blue LED Flash Slowly

Post by pzygmunt » Sat May 28, 2016 7:27 am

....Maybe wifi coverage is too weak?

Post Reply