SUPLA Scripts

THEND
Posty: 26
Rejestracja: śr paź 17, 2018 12:46 pm

sob paź 20, 2018 8:26 pm

pi@raspberrypizero:~ $ uname -a
Linux raspberrypizero 4.14.71+ #1145 Fri Sep 21 15:06:38 BST 2018 armv6l GNU/Linux

U mnie wygląda to inaczej:
Załączniki
ERROR-suplascripts.PNG
ERROR-suplascripts.PNG (30.77 KiB) Przejrzano 1957 razy
Awatar użytkownika
pzygmunt
Posty: 8693
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

ndz paź 21, 2018 8:21 am

speak na poczatku sudo
THEND
Posty: 26
Rejestracja: śr paź 17, 2018 12:46 pm

ndz paź 21, 2018 12:40 pm

pzygmunt pisze:
ndz paź 21, 2018 8:21 am
speak na poczatku sudo
Co to znaczy?
Awatar użytkownika
pzygmunt
Posty: 8693
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

ndz paź 21, 2018 6:43 pm

Miało być
Dodaj na początku sudo
THEND
Posty: 26
Rejestracja: śr paź 17, 2018 12:46 pm

ndz paź 21, 2018 6:53 pm

pzygmunt pisze:
ndz paź 21, 2018 6:43 pm
Miało być
Dodaj na początku sudo
W którym momencie? Gdy wykonuję komendę speak sudo ... dostaję komunikat:
-bash: speak: command not found
Awatar użytkownika
pzygmunt
Posty: 8693
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

ndz paź 21, 2018 7:01 pm

„Speak” to mi autokorekta wcisnęła zamiast „Dodaj”
THEND
Posty: 26
Rejestracja: śr paź 17, 2018 12:46 pm

ndz paź 21, 2018 7:12 pm

pzygmunt pisze:
ndz paź 21, 2018 7:01 pm
„Speak” to mi autokorekta wcisnęła zamiast „Dodaj”
Rozumiem :)

Już tak próbowałem (pisałem, o tym kilka postów wcześniej), ten sam błąd :(
Już zaczynam poddawać się.
Załączniki
ERROR-sudo-suplascripts.PNG
ERROR-sudo-suplascripts.PNG (30.54 KiB) Przejrzano 1913 razy
Awatar użytkownika
fracz
Posty: 1833
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

pn paź 22, 2018 5:50 am

sudo nic tu nie da, bo problem jest z jakiegoś powodu wewnątrz kontenera.

Nie wiem o co chodzi, bo u mnie na tej samej architekutrze działa bez problemu.

Jeśli chcesz podłubać - musimy najpierw dojść która komenda powoduje problem, bo tam wszystkie wykonywane są w grupie i w sumie nie wiadomo która ma problem. Strzelam, że pierwsze apt-get update ale nie wiadomo...

W pliku docker/Dockerfile usuń wszystko poniżej linii WORKDIR /var/www - to wybuduje "czysty" kontener i to powinno się udać.

Następnie wejdź do kontenera:

Kod: Zaznacz cały

docker exec -it supla-scripts bash
I próbuj wykonywać wszystkie komendy, które usunąłeś po kolei. Któraś z nich powinna dać ten błąd...

Kod: Zaznacz cały

apt-get update
apt-get install -y --no-install-recommends libicu-dev
apt-get install -y --no-install-recommends libpq-dev
apt-get install -y --no-install-recommends ca-certificates
apt-get install -y --no-install-recommends ssl-cert
...
THEND
Posty: 26
Rejestracja: śr paź 17, 2018 12:46 pm

pn paź 22, 2018 6:38 am

Kontener wybudował się teraz ale nie mogę do niego wejść:
Załączniki
Suplascripts-Docker.PNG
Suplascripts-Docker.PNG (20.4 KiB) Przejrzano 1875 razy
Awatar użytkownika
fracz
Posty: 1833
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

pn paź 22, 2018 7:11 am

Kod: Zaznacz cały

docker exec -it suplascripts bash
ODPOWIEDZ

Wróć do „Projekty użytkowników”