Sonoff Pow wydanie R2 - firmware

Post Reply
User avatar
TomekSkarabeusz
Posts: 31
Joined: Tue May 29, 2018 6:14 am

Fri May 24, 2019 3:52 pm

Dzisiaj dotarł do mnie POW R2. Wgrywam ostatnią wersję djack 2017 z 19.05.2019
Operacja zakończona sukcesem. Po wpięciu do sieci nie nie widać SIDa supli. Nie świeci też żadna kontrolka (powinna?)
Uprzedzając:
  • czyściłem blankiem
  • L i N podłączone prawidłowo
Co robię nie tak?
walanar1
Posts: 22
Joined: Fri May 18, 2018 5:31 pm

Fri May 24, 2019 9:02 pm

TomekSkarabeusz wrote:
Fri May 24, 2019 3:52 pm
Dzisiaj dotarł do mnie POW R2. Wgrywam ostatnią wersję djack 2017 z 19.05.2019
Operacja zakończona sukcesem. Po wpięciu do sieci nie nie widać SIDa supli. Nie świeci też żadna kontrolka (powinna?)
Uprzedzając:
  • czyściłem blankiem
  • L i N podłączone prawidłowo
Co robię nie tak?
Czyściłes bankiem 1MB bo POW R2 ma
4MB więc należy czyścić 4 razy 1MB.
Ja czyscilem opcją erase w najnowszej wersji Flash Download Tools v3.6.5
potem zgodnie z opisem djack 2017 po zakończeniu i resecie powinna migać szybko LED u mnie śmiga.
Attachments
img_1558731450794.jpg
img_1558731450794.jpg (205.27 KiB) Viewed 602 times
walanar1
Posts: 22
Joined: Fri May 18, 2018 5:31 pm

Sat May 25, 2019 9:32 am

djack2017 wrote:
Thu May 23, 2019 6:55 pm
walanar1 wrote:
Thu May 23, 2019 1:34 pm
djack2017 wrote:
Thu May 23, 2019 12:52 pm

Nie ma bladego pojęcia co to za produkt ale z pewnością ten soft nie będzie z nim współpracował.
Tu jest opis
https://www.letscontrolit.com/forum/vie ... php?t=6341
"There is only the hard_SONOFF_POW version, but you need 4 mb of flash. BW-SHP6 has only 1 mb "
Nie da rady, za mało pamięci
Ale twój soft jest mniejszy od 1MB
I powinien się zmieścić czy możesz przekompilować wyjścia gpio wg tego opisu
I changed the flash from 1MB to 4 MB (Winbond)
I used a new flash for SonOFF (ESP_Easy_mega-20190301_hard_SONOFF_POW_4M.bin)
And it works :)
Attachments
pow.png
pow.png (55.5 KiB) Viewed 581 times
User avatar
TomekSkarabeusz
Posts: 31
Joined: Tue May 29, 2018 6:14 am

Sat May 25, 2019 12:37 pm

walanar1 wrote:
Fri May 24, 2019 9:02 pm
Czyściłes bankiem 1MB bo POW R2 ma
4MB więc należy czyścić 4 razy 1MB.
Ja czyscilem opcją erase w najnowszej wersji Flash Download Tools v3.6.5
potem zgodnie z opisem djack 2017 po zakończeniu i resecie powinna migać szybko LED u mnie śmiga.
Dalej bez zmian.
Czyściłem Erase z Flash Download Tools v3.6.5
Wgrywałem 4 blanki na 0x00000, 0x10000, 0x20000 i 0x30000
Wgrałem blank_4M przez FlashESP8266
Niby wszystko się udało.
Potem wgrywałem boot_v1.5.bin, sonoff_pow_R2_zabbix.bin i esp_init_data_default.bin zarówno poprzez Flash Download Tools v3.6.5 jakii ESP8266Flasher.
Nic nie pomaga.
W putty latają same "krzaki"
scoobi
Posts: 20
Joined: Sun Dec 17, 2017 9:38 am

Sat May 25, 2019 6:07 pm

ja też miałem na początku problem, spróbuj prędkość programowania 9600 ( dout) strasznie wolno to idzie ale mi po tym wstał. oczywiście najpierw czyszczenie blankiem
djack2017
Posts: 320
Joined: Mon Nov 27, 2017 7:36 am

Sun May 26, 2019 7:30 pm

TomekSkarabeusz wrote:
Sat May 25, 2019 12:37 pm
W putty latają same "krzaki"
Pamiętasz, że prędkość putty przy debugowaniu jest 4800 ?
User avatar
TomekSkarabeusz
Posts: 31
Joined: Tue May 29, 2018 6:14 am

Sun May 26, 2019 7:51 pm

djack2017 wrote:
Sun May 26, 2019 7:30 pm
Pamiętasz, że prędkość putty przy debugowaniu jest 4800 ?
Przy prędkości 4800 bez zmian.

Udało mi się coś zmienić przez esptool. Najpierw czyściłem blank_4MB przez ESPEasy Flasher a potem:

Code: Select all

esptool.py --port COM2 erase_flash
i

Code: Select all

esptool.py --port COM2 write_flash -fs 4MB -fm dout 0x00000 boot_v1.5.bin 0x01000 sonoff_pow_R2_zabbix.bin 0xfc000 esp_init_data_default.bin
Dalej nie mam łączności ale putty zaczął coś wyświetlać. Cały czas b. szybko leci:

Code: Select all

 ets Jan  8 2013,rst cause:1, boot mode:(3,1)

load 0x40100000, len 1856, room 16
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
  SPI Speed      : 40MHz
  SPI Mode       : DOUT
  SPI Flash Size & Map: 32Mbit(512KB+512KB)
jump to run user1 @ 1000

rf_cal[0] !=0x05,is 0xFF
djack2017
Posts: 320
Joined: Mon Nov 27, 2017 7:36 am

Mon May 27, 2019 6:22 am

Ja w przypadku nowego sonoffa robie takie magiczne działania:
- podłączony RS232 (3.3V) bez izolacji galwanicznej (ODPIĘTE 230V)
- w pierwszej sesji czyszczę blankiem 1MB (ew. 2MB)
- w drugiej sesji wgrywam boot... i esp_ini...
- w trzeciej sesji wgrywam właściwy firmware
do debugowania:
- podłączony RS232 z izolacją galwaniczną (włączone 230V):
szybkość 4800, odłączona fizycznie linia RX(sonoff) <-> TX (PC-et)
- odblokowana rejestracja urządzeń na serwerze CLOUD
djack2017
Posts: 320
Joined: Mon Nov 27, 2017 7:36 am

Mon May 27, 2019 6:48 am

walanar1 wrote:
Sat May 25, 2019 9:32 am
I used a new flash for SonOFF (ESP_Easy_mega-20190301_hard_SONOFF_POW_4M.bin)
And it works :)
A próbowałeś może wgrać "w ciemno" mój firmware dla wersji sonoff-pow?
http://djack.com.pl/modules.php?name=Do ... it&lid=328
walanar1
Posts: 22
Joined: Fri May 18, 2018 5:31 pm

Mon May 27, 2019 1:30 pm

djack2017 wrote:
Mon May 27, 2019 6:48 am
walanar1 wrote:
Sat May 25, 2019 9:32 am
I used a new flash for SonOFF (ESP_Easy_mega-20190301_hard_SONOFF_POW_4M.bin)
And it works :)
A próbowałeś może wgrać "w ciemno" mój firmware dla wersji sonoff-pow?
http://djack.com.pl/modules.php?name=Do ... it&lid=328
Wgrałem dzisiaj i poszło bez problemu łączy się z chmurą widać w aplikacji wirtualnie się przełącza ale fizycznie nie uruchamia przekaźnika i nie pokazuje danych,tak jak pisałem wcześniej należałoby dostosować wyjścia gpio.
Post Reply