Automatyczna instalacja supla (server,cloud,dev)

Post Reply
User avatar
pzygmunt
Posts: 7077
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Tue Jan 24, 2017 7:19 pm

reCaptcha nie będzie działać bez konta w google
Seba5120
Posts: 307
Joined: Mon Oct 31, 2016 1:33 pm

Tue Jan 24, 2017 7:23 pm

pzygmunt wrote:
Tue Jan 24, 2017 7:19 pm
reCaptcha nie będzie działać bez konta w google
A gdzie może być problem, że nam ten port wywala np. przy próbie założenia konta?
User avatar
pzygmunt
Posts: 7077
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Tue Jan 24, 2017 7:48 pm

https://github.com/SUPLA/supla-cloud/bl ... t.php#L173

return 'https://'.$request->getHost().$this->router->generate('_account_create_here_lc', array('locale' => $request->getLocale()));

zmiana na

return 'https://'.$request->getHost().':1234'.$this->router->generate('_account_create_here_lc', array('locale' => $request->getLocale()));

gdzie 1234 to numer portu
User avatar
pzygmunt
Posts: 7077
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Tue Jan 24, 2017 8:06 pm

Jeszcze raz kompilacja po pisałem z głowy a ma być lekko inaczej

w
https://github.com/SUPLA/supla-core/blo ... kefile#L47

ma być
g++ -L/usr/include/mysql -L/usr/src/openssl/lib -pthread -lrt -o "supla-server" $(OBJS) $(USER_OBJS) $(LIBS)

w
https://github.com/SUPLA/supla-core/blo ... dir.mk#L99

ma być
g++ -D__OPEN_SSL=1 -I/usr/include/mysql -I/usr/src/openssl/include -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"

w
https://github.com/SUPLA/supla-core/blo ... ir.mk#L106

ma być
gcc -O3 -Wall -I/usr/src/openssl/include -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
Zybi
Posts: 1389
Joined: Sun Jun 26, 2016 4:24 pm

Tue Jan 24, 2017 8:52 pm

A jak sobie poradzić z takim komunikatem:

Oops! An Error Occurred
The server returned a "500 Internal Server Error".
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.


przy próbie pobrania historii pomiarów z czujnika np. DHT11
User avatar
slawek
Posts: 2216
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Tue Jan 24, 2017 10:45 pm

Seba5120 wrote:
Tue Jan 24, 2017 6:55 pm
slawek wrote:
Tue Jan 24, 2017 6:51 pm
Ja mam z gotowego obrazu - na RBPi3.
Mam też problem z captcha - na wirtualce wcześniej wyłączyłem, natomiast na malince nie mogę
A jak Sławku masz skonfigurowane e-mail?
Działa Ci wysyłka linków aktywacyjnych?

Jak zakładam konto, to przekierowuje po porcie nowym skonfigurowanym, w moim przypadku 1111
A jak próbuję się zalogować do serwera to usuwa port i komunikat o braku połączenia...
Linki wysyła, ale wyłączyłem recaptcha, bo wpisałem klucze z konta, ale nie mam okna, tylko komunikat "niepoprawny recaptcha".
Dorzucam mój konfig na priv - oczywiście hasło do maila musisz wpisać właściwe dla skrzynki wychodzącej i jeśli używasz recaptcha to klucze...
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
Seba5120
Posts: 307
Joined: Mon Oct 31, 2016 1:33 pm

Wed Jan 25, 2017 6:31 am

pzygmunt wrote:
Tue Jan 24, 2017 8:06 pm
Jeszcze raz kompilacja po pisałem z głowy a ma być lekko inaczej

w
https://github.com/SUPLA/supla-core/blo ... kefile#L47

ma być
g++ -L/usr/include/mysql -L/usr/src/openssl/lib -pthread -lrt -o "supla-server" $(OBJS) $(USER_OBJS) $(LIBS)

w
https://github.com/SUPLA/supla-core/blo ... dir.mk#L99

ma być
g++ -D__OPEN_SSL=1 -I/usr/include/mysql -I/usr/src/openssl/include -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"

w
https://github.com/SUPLA/supla-core/blo ... ir.mk#L106

ma być
gcc -O3 -Wall -I/usr/src/openssl/include -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"

Wyeliminowalo mi to błędy w porcie.
Mam nadzieję że wszystkie :)
Dzięki :)
Seba5120
Posts: 307
Joined: Mon Oct 31, 2016 1:33 pm

Wed Jan 25, 2017 4:29 pm

pzygmunt wrote:
Tue Jan 24, 2017 7:48 pm
https://github.com/SUPLA/supla-cloud/bl ... t.php#L173

return 'https://'.$request->getHost().$this->router->generate('_account_create_here_lc', array('locale' => $request->getLocale()));

zmiana na

return 'https://'.$request->getHost().':1234'.$this->router->generate('_account_create_here_lc', array('locale' => $request->getLocale()));

gdzie 1234 to numer portu
Udało mi się skonfigurować konto i dostaję wiadomości z aktywacją :-)

Tylko mam problem nadal z portem podczas logowania do panelu.
Po wpisaniu adresu e-mail i zatwierdzeniu przekierowuje mnie na adres bez portu i się wysypuje.
Gdzie jeszcze muszę ustawić port aby podczas logowania przeszedł do okna wpisania hasła?
alv
Posts: 74
Joined: Sat Jul 09, 2016 11:36 am

Thu Jan 26, 2017 8:30 am

Słuchajcie, ten instalator miał być odpowiedzią na wszystkie problemy, np. konieczność kompilowania bibliotek ssl. Wszystko to jest zawarte w moim oprogramowaniu.

Zawarte jest to w 3 krokach:

Code: Select all

- name: Check if libssl is already compiled and installed
  stat: path={{ supla_path}}/lib/libssl.so
  register: compiled_openssl
  tags: supla-server

- name: Copy openssl_compile.sh 
  template: src=openssl_compile.sh.j2 dest={{ supla_path  }}/src/openssl_compile.sh mode=655  
  tags: supla-server
  when: compiled_openssl.stat.exists == False 

- name: Make specific ssl lib for this os
  command: /home/supla/src/openssl_compile.sh
  when: compiled_openssl.stat.exists == False
  notify: restart supla-server 
  tags: supla-server
Tworzy się skrypt z takim kodem:

Code: Select all


cd /usr/src
mkdir -p /usr/src/openssl
rm -rf /usr/src/{{ supla_openssl_version }}
rm -f /usr/src/{{ supla_openssl_version}}.tar.gz
wget https://www.openssl.org/source/{{ supla_openssl_version  }}.tar.gz
tar zxvf /usr/src/{{ supla_openssl_version  }}.tar.gz
cd /usr/src/{{ supla_openssl_version  }} 
make clean
./config --prefix=/usr/src/openssl shared
sed -e 's/no\-ssl2//g' /usr/src/{{ supla_openssl_version  }}/Makefile
make depend -j {{ ansible_processor_cores }} 
make install -j {{ ansible_processor_cores }}
cp /usr/src/openssl/lib/lib*.so* {{ supla_path  }}/lib/
rm -rf /usr/src/openssl
@Zybi, może nie wykonał się poprawnie, ale wtedy można wykonać playbooka jeszcze raz, albo po prostu /usr/local/sbin/openssl_compile.ssh

Wcześniej nie mogłem odpisać, ponieważ mam problemy z czasem.
alv
Posts: 74
Joined: Sat Jul 09, 2016 11:36 am

Thu Jan 26, 2017 8:38 am

Zybi wrote:
Tue Jan 24, 2017 8:52 pm
A jak sobie poradzić z takim komunikatem:

Oops! An Error Occurred
The server returned a "500 Internal Server Error".
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.


przy próbie pobrania historii pomiarów z czujnika np. DHT11
Co mówią error logi apache2?
Post Reply