Problem z certyfikatem po stronie serwera SUPLA

amplif3r
Posts: 17
Joined: Sun Aug 28, 2022 8:09 pm

Post

Cześć. Kod urządzenia tworzyłem sam. Przy wykorzystaniu GUID i AUTH Key urządzenie się dodaje do chmury. W momencie, gdy przechodzę na interfejs www i w trybie konfiguruacji podaje serwer oraz maila dostaje błąd na poziomie sesji SSL. Wcześniej takich problemów nie miałem.
Urządzenie ESP32 ATOM M5 (jeśli ma to znaczenie)
Biblioteka supla 23.12 (na starszych też nie działało)

Code: Select all

Establishing encrypted connection with: svr63.supla.org (port: 2016)
[ 40842][E][ssl_client.cpp:37] _handle_error(): [start_ssl_client():187]: (-8576) X509 - The CRT/CRL/CSR format is invalid, e.g. different type expected
[ 40845][E][WiFiClientSecure.cpp:144] connect(): start_ssl_client: -8576
SSL error: -8576, X509 - The CRT/CRL/CSR format is invalid, e.g. different type expected
Connection fail (0). Server: svr63.supla.org
User avatar
klew
Posts: 8763
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

amplif3r wrote: Fri Jan 12, 2024 5:40 pm Cześć. Kod urządzenia tworzyłem sam. Przy wykorzystaniu GUID i AUTH Key urządzenie się dodaje do chmury. W momencie, gdy przechodzę na interfejs www i w trybie konfiguruacji podaje serwer oraz maila dostaje błąd na poziomie sesji SSL. Wcześniej takich problemów nie miałem.
Urządzenie ESP32 ATOM M5 (jeśli ma to znaczenie)
Biblioteka supla 23.12 (na starszych też nie działało)
Pewnie nie masz ustawionych certyfikatów.
Zerknij do przykładu WebInterface - tam są ustawione dwa certyfikaty
Widzimy się na Supla Offline Party vol. 2 :!:
amplif3r
Posts: 17
Joined: Sun Aug 28, 2022 8:09 pm

Post

Oczywiście, że tak:) Wielkie dzięki.

Return to “supla-dev”