Yunshan wgranie softu.

darius
Posts: 55
Joined: Mon Oct 24, 2016 7:35 pm

Post

Cześć
kupiłem moduł Yunshan jak w załączniku i chcę wgrać do niego suplę (in-can lub multibard).
Próbowałem wykorzystać instrukcję https://www.smartnydom.pl/forum/supla/w ... tool-v1-2/
z cp2102 łączę
GND - GND
TX - RX
RX - TX

a zasilanie podaję z osobnego źródła 12V.
Zwieram zworki boot i podaję zasilanie ale komunikacji brak. Dostaję timeout.
Jak poznać że ten moduł jest w trybie flashowania?
Raz dioda świeci się na niebiesko raz na czerwono.
Ile czasu po podaniu zasilania ta zworka powinna być założona?
Próbowałem już kilku konfiguracji i ciągle timeout.

Pomożecie laikowi.
You do not have the required permissions to view the files attached to this post.
User avatar
wojtas567
Posts: 2219
Joined: Sun Apr 03, 2016 7:16 pm
Location: Olsztyn

Post

Dla pewności załóż zworę na boot na stałe, podczas programowania oczywiście
podłącz zasilanie i spróbuj wgrać jeżeli nie idzie to zamień przewody tx z rx i zobacz wtedy zacznie się wgrywać.
Pozdrawiam
Wojtek
darius
Posts: 55
Joined: Mon Oct 24, 2016 7:35 pm

Post

Dzięki za podpowiedź ale nic to nie dało.
Dalej mam błędy:

('self.chip: ', 'ESP8266')
RF option applied...
test offset : 0 0x0
case ok
test offset : 262144 0x40000
case ok
======
CONNECT BAUD: 115200
============
....._____....._____....._____....._____....._____....._____....._____....._____....._____....._____[2019-03-06 12:02:00,880][ESP8266Loader_spi[1]][espDownloader.py][line:351][ERROR]: Chip sync error: Failed to connect to ESP8266: Invalid head of packet ('\xe2')
[2019-03-06 12:02:00,880][ESP8266Loader_spi[1]][espDownloader.py][line:439][ERROR]: ESP8266 Chip sync error esp_sync_blocking.


po połączeniu modułu i próby połączenia przez putty z różnymi prędkościami (9600/78880/115200)
Serial: COM3

jedyne co udaje mi się uzyskać to krzaki w stylu:
b▒▒o{$▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒

moduł też dziwnie trzeszczy.
Czy to może oznaczać że jest walnięty?
Czy to jakoś idzie zmierzyć?
Gucio2607.
Posts: 508
Joined: Tue Aug 22, 2017 1:56 pm

Post

Ja zworkę tylko mam podczas podłączania..
Zainstalowane:
11x sonoff basic, 1x sonoff gate, 1x Yunshan, 2x H801, 7x sonoff touch(1,2,3 gang), 1x sonoff 4ch PRO
cino111
Posts: 714
Joined: Mon May 07, 2018 8:00 pm

Post

Daj z programatora
GND - GND
TX - RX
RX - TX
5V - na konektor gdzie podłączałeś 12v (tylko ten z + )
załóż zworkę
darius
Posts: 55
Joined: Mon Oct 24, 2016 7:35 pm

Post

Czyli mam zrezygnować z zewnętrznego źródła zasilania i podać na wejście 5V z modułu USB?
a co z minusem mam go jakoś zmostkować czy zostawić pusty?
cino111
Posts: 714
Joined: Mon May 07, 2018 8:00 pm

Post

Minus na pin przy tx i rx. Gnd
darius
Posts: 55
Joined: Mon Oct 24, 2016 7:35 pm

Post

Zrobiłem jak poleciłeś i coś drgnęło.
Udało się połączyć z modułem co więcej zaczęło się wgrywać z ustawieniami jak niżej:
Przechwytywanie.PNG
Po tym zdjąłem zasilanie i zworę boot.
Po ponownym zasileniu dioda od wifi mruga nieregularnie przez kilka sekund i poźniej gaśnie a moduł nie rozgłasza sieci wifi.
Próbowałem podawać zarówno 5V jak i 12V to samo.
Przed wgraniem softu najpierw użyłem przycisku erase.
You do not have the required permissions to view the files attached to this post.
cino111
Posts: 714
Joined: Mon May 07, 2018 8:00 pm

Post

Nie wiem co to za soft, ale multiboard masz tu viewtopic.php?f=11&t=3843
Wgraj to bez pliku init_data.
Wyczyść najpierw moduł.
darius
Posts: 55
Joined: Mon Oct 24, 2016 7:35 pm

Post

Przez wyczyść moduł rozumiemy użycie przycisku erase w programie flashujacym czy coś więcej? Wgrywam właśnie Soft espablo gdzieś na forum wyczytałem żeby dodać init. Próbowałem też bez tego pliku. Nic będę kombinować dalej. I tak już dużo pomogłes bo ruszyłem z miejsca :)

Return to “Yunshan wi-fi relay module”