Arduino

Post Reply
Tadeusz
Posts: 9
Joined: Wed Jul 12, 2017 6:38 am

Tue Sep 19, 2017 9:27 am

Proszę o zwrócenie uwagi w nowej wersji aplikacji Arduino na obsługę modułu Ethernet Shield. Obecnie testuję Arduino Mega 2560 z modułem Ethernet Shield i aplikacją w wersji 1.1. Zaobserwowałem, że bezpośrednio po podłączeniu zasilania, moduł nie łączy się z siecią. Połączenie zostaje zestawione dopiero po zresetowaniu modułu sieciowego. Zakładając konieczność zdalnego zarządzania Supla, bez fizycznego dostępu do modułu i przypadkowy zanik fazy jest to wg mnie błąd mocno ograniczający funkcjonalność projektu.

Tadeusz
User avatar
pzygmunt
Posts: 6857
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Tue Sep 19, 2017 9:32 am

To raczej kwestia Twojej implementacji. Gdzieś popełniasz błąd.
User avatar
wojtas567
Posts: 1777
Joined: Sun Apr 03, 2016 7:16 pm
Location: Olsztyn

Tue Dec 12, 2017 11:23 am

Czy jest w planach aktualizacja do nowszej wersji?
bo tu jest jeszcze 1.1.
Pozdrawiam
Wojtek
User avatar
Piotr61
Posts: 55
Joined: Fri Sep 15, 2017 12:59 pm

Fri Dec 22, 2017 1:51 pm

wojtas567 wrote:
Tue Dec 12, 2017 11:23 am
Czy jest w planach aktualizacja do nowszej wersji?
bo tu jest jeszcze 1.1.
Wprawdzie cyferki się nie zmieniły ale w samej bibliotece sporo zmian, nowości i ... kilka prostych błędów(literówek) do "ogarnięcia" w 5 minut :D
https://github.com/SUPLA/arduino/tree/m ... uplaDevice

Piotr

PS
@pzygmunt - dzięki :P
"Dopóki nie skorzystałem z Internetu, nie wiedziałem, że na świecie jest tylu idiotów" - Stanisław Lem
User avatar
wojtas567
Posts: 1777
Joined: Sun Apr 03, 2016 7:16 pm
Location: Olsztyn

Fri Dec 22, 2017 2:02 pm

czyli jest szansa, że będzie stabilniejsze :)
Pozdrawiam
Wojtek
User avatar
pzygmunt
Posts: 6857
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Fri Dec 22, 2017 2:15 pm

wojtas567 wrote:
Fri Dec 22, 2017 2:02 pm
czyli jest szansa, że będzie stabilniejsze :)
Wersja na githubie nie jest jeszcze ukończona
User avatar
Piotr61
Posts: 55
Joined: Fri Sep 15, 2017 12:59 pm

Sat Dec 23, 2017 6:45 pm

pzygmunt wrote:
Fri Dec 22, 2017 2:15 pm
Wersja na githubie nie jest jeszcze ukończona
Chyba że tak - to czekamy na wersję finalną.

Piotr
"Dopóki nie skorzystałem z Internetu, nie wiedziałem, że na świecie jest tylu idiotów" - Stanisław Lem
User avatar
Piotr61
Posts: 55
Joined: Fri Sep 15, 2017 12:59 pm

Thu May 03, 2018 7:34 pm

Czekałem, czekałem i się doczekałem :P
Ponieważ Arduino i SUPLA są jakoś mało popularne, to postanowiłem w ten długi majowy "łykend" coś spłodzić, a że ciepło się zrobiło , to mi takie coś wyszło :mrgreen:

Jak widać(choć słabo) na obrazkach, konfigurujemy urządzenie standardowo przez 192.168.4.1.
Ikona sterowanie służy do załączenia lub wyłączenia termostatu, a ikona wentylatora pokazuje tylko stan w jakim znajduje się odbiornik, czyli w moim przypadku klimatyzator i nie można za jej pomocą niczego włączyć czy też wyłączyć.
No to tak w skrócie, bo mnie już palce od klepania w klawiaturę bolą :lol:

Pozdrawiam.
Piotr

P.S.
Termostatem jest Sonoff Basic.

arduino_supla.png
arduino_supla.png (99.83 KiB) Viewed 17297 times



P.S2
Jak to mówią, lepiej późno niż wcale :oops:
Termostat działa NIEZALEŻNIE, czyli bez względu na stan połączenia WiFi.
"Dopóki nie skorzystałem z Internetu, nie wiedziałem, że na świecie jest tylu idiotów" - Stanisław Lem
Post Reply