DHT 11 sensor does not work

Post Reply
jarvis007
Posts: 3
Joined: Thu Mar 08, 2018 4:12 pm

DHT 11 sensor does not work

Post by jarvis007 » Thu Mar 08, 2018 4:23 pm

Hello, I installed the firmware sonoff_dimmer_DHT11_v2.5.3_p5.rar (https://github.com/SUPLA/ESP8266/tree/m ... off/v2.5.3)
connected the sensor, but I do not see the temperature (sensor working)
Attachments
400px-IMG_1589.jpg
400px-IMG_1589.jpg (46.45 KiB) Viewed 8860 times

Zybi
Posts: 1128
Joined: Sun Jun 26, 2016 4:24 pm

Re: DHT 11 sensor does not work

Post by Zybi » Thu Mar 08, 2018 5:27 pm

Are you sure you have connected the sensor correctly?
I have the impression, that the yellow wire is connected to the NC and not to the input S (data).

jarvis007
Posts: 3
Joined: Thu Mar 08, 2018 4:12 pm

Re: DHT 11 sensor does not work

Post by jarvis007 » Fri Mar 09, 2018 6:41 am

real photo
Attachments
IMG_20180309_112052.jpg
IMG_20180309_112052.jpg (71.89 KiB) Viewed 8831 times
IMG_20180309_112225.jpg
IMG_20180309_112225.jpg (109.19 KiB) Viewed 8831 times
photo_2018-03-09_11-36-15.jpg
photo_2018-03-09_11-36-15.jpg (42.48 KiB) Viewed 8831 times

Komar000
Posts: 30
Joined: Mon Feb 12, 2018 9:28 am

Re: DHT 11 sensor does not work

Post by Komar000 » Thu Mar 15, 2018 3:41 pm

What kind of power you use?
If You use power supply from usb,try connect sonoff to 230v.

jarvis007
Posts: 3
Joined: Thu Mar 08, 2018 4:12 pm

Re: DHT 11 sensor does not work

Post by jarvis007 » Sat Mar 17, 2018 6:50 am

I connect to 220v

DaveRodda
Posts: 1
Joined: Thu Nov 22, 2018 6:07 pm

Re: DHT 11 sensor does not work

Post by DaveRodda » Thu Nov 22, 2018 6:38 pm

Hello...I had the same problem with module with DHT11 and red LED. One of resistance was 1kOhm instead 10kOhm. Please, check it carefully.Have a multimeter handy? Test your connections to and on the module.You should take a delay of 2 seconds between readings, - see datasheet.
I do not know how it behaves it readings are made too fast.

complete pcb

Post Reply