[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

groszek33
Posts: 49
Joined: Sun Feb 11, 2018 12:15 pm

Tue Mar 05, 2019 5:32 pm

Cześć walczę już drugi dzień zgodnie z instrukcją
do chodzę do 4. punktu i dostaje taki obraz już od czytania dostaje na głowę nie wiem o co chodzi
supla-01.jpg
supla-01.jpg (76.03 KiB) Viewed 555 times
Odpadam nowa instalacja nowa karta sd i lipa
Kto pyta nie błądzi:))
User avatar
lesny8
Posts: 865
Joined: Mon Dec 11, 2017 9:43 pm

Tue Mar 05, 2019 5:55 pm

Zmień standalone na proxy w pliku .env dla supla-docker
groszek33
Posts: 49
Joined: Sun Feb 11, 2018 12:15 pm

Tue Mar 05, 2019 6:02 pm

lesny8 wrote:
Tue Mar 05, 2019 5:55 pm
Zmień standalone na proxy w pliku .env dla supla-docker
Leśny dzięki co ja się .... :D
Kto pyta nie błądzi:))
groszek33
Posts: 49
Joined: Sun Feb 11, 2018 12:15 pm

Tue Mar 05, 2019 6:26 pm

Leśny jest ok ale nie widzę go z zewnątrz
Nie instalowałem jeszcze supla-scripts
Kto pyta nie błądzi:))
cino111
Posts: 707
Joined: Mon May 07, 2018 8:00 pm

Tue Mar 05, 2019 6:45 pm

groszek33 wrote:
Tue Mar 05, 2019 6:26 pm
Leśny jest ok ale nie widzę go z zewnątrz
Nie instalowałem jeszcze supla-scripts
Przekierowałeś porty 80 i 443 na routerze?
vicam
Posts: 8
Joined: Thu Feb 21, 2019 3:22 pm

Tue Mar 05, 2019 6:50 pm

lesny8 wrote:
Tue Mar 05, 2019 1:02 pm
vicam wrote:
Tue Mar 05, 2019 11:04 am
Hairpin NAT
To musi działać. Może coś źle zrobiłeś. Odpal terminal klepnij komendy i pokaż jaki masz config.

Code: Select all

ip address print
ip route print
ip firewall nat print
Hej
ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
0 ;;; defconf
192.168.99.5/24 192.168.99.0 ether2-master
1 x.y.z.226/30 z.y.z.224 ether1

ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 x.y.z.225 1
1 ADC x.y.z.224/30 x.y.z.226 ether1 0
2 ADC 192.168.99.0/24 192.168.99.5 bridge 0

ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 X chain=srcnat action=src-nat to-addresses=192.168.99.111 src-address=192.168.99.0/24 dst-address=192.168.99.0/24 log=no log-prefix=""

1 ;;; Hairpin NAT
chain=srcnat action=masquerade src-address=192.168.99.0/24 dst-address=!192.168.99.0/24 log=no log-prefix=""

2 ;;; defconf: masquerade
chain=srcnat action=masquerade out-interface=ether1 log=no log-prefix=""

3 chain=dstnat action=dst-nat to-addresses=192.168.99.111 to-ports=2016 protocol=tcp in-interface=ether1 dst-port=2016 log=no log-prefix=""

4 chain=dstnat action=dst-nat to-addresses=192.168.99.111 to-ports=80 protocol=tcp in-interface=ether1 dst-port=80 log=no log-prefix=""

5 chain=dstnat action=dst-nat to-addresses=192.168.99.111 to-ports=22 protocol=tcp in-interface=ether1 dst-port=22 log=no log-prefix=""

6 chain=dstnat action=dst-nat to-addresses=192.168.99.111 to-ports=443 protocol=tcp in-interface=ether1 dst-port=443 log=no log-prefix=""

7 chain=dstnat action=dst-nat to-addresses=192.168.99.111 to-ports=2015 protocol=tcp in-interface=ether1 dst-port=2015 log=no log-prefix=""

8 X chain=srcnat action=masquerade protocol=tcp src-address=192.168.99.0/24 dst-address=192.168.99.111 dst-port=443 log=no log-prefix=""

9 chain=dstnat action=dst-nat to-addresses=192.168.99.11 to-ports=80 protocol=tcp dst-address=192.168.99.5 dst-address-type=local dst-port=80 log=no log-prefix=""

10 chain=dstnat action=dst-nat to-addresses=192.168.99.11 to-ports=443 protocol=tcp dst-address=192.168.99.5 dst-address-type=local dst-port=443 log=no log-prefix=""


Raspberry jest na adresie 192.168.99.111 a mikrotik na 192.168.99.5 - to jest ostatnia wersja którą testowałem
groszek33
Posts: 49
Joined: Sun Feb 11, 2018 12:15 pm

Tue Mar 05, 2019 6:53 pm

cino111 wrote:
Tue Mar 05, 2019 6:45 pm
groszek33 wrote:
Tue Mar 05, 2019 6:26 pm
Leśny jest ok ale nie widzę go z zewnątrz
Nie instalowałem jeszcze supla-scripts
Przekierowałeś porty 80 i 443 na routerze?
a dokładnie to jak przekierować? bo się cosik gubię
Kto pyta nie błądzi:))
cino111
Posts: 707
Joined: Mon May 07, 2018 8:00 pm

Tue Mar 05, 2019 7:24 pm

groszek33 wrote:
Tue Mar 05, 2019 6:53 pm
cino111 wrote:
Tue Mar 05, 2019 6:45 pm
groszek33 wrote:
Tue Mar 05, 2019 6:26 pm
Leśny jest ok ale nie widzę go z zewnątrz
Nie instalowałem jeszcze supla-scripts
Przekierowałeś porty 80 i 443 na routerze?
a dokładnie to jak przekierować? bo się cosik gubię
Musisz poszukać na routerze, ale mniej więcej jak na scr. Port 2015 I 2016 są do działania apki na telefonie, a 80 i 443 do wejścia z zewnątrz.
Attachments
Screenshot_20190305-202223_Samsung Internet.jpg
Screenshot_20190305-202223_Samsung Internet.jpg (511.59 KiB) Viewed 512 times
groszek33
Posts: 49
Joined: Sun Feb 11, 2018 12:15 pm

Tue Mar 05, 2019 7:41 pm

cino111 wrote:
Tue Mar 05, 2019 7:24 pm
groszek33 wrote:
Tue Mar 05, 2019 6:53 pm
cino111 wrote:
Tue Mar 05, 2019 6:45 pm


Przekierowałeś porty 80 i 443 na routerze?
a dokładnie to jak przekierować? bo się cosik gubię
Musisz poszukać na routerze, ale mniej więcej jak na scr. Port 2015 I 2016 są do działania apki na telefonie, a 80 i 443 do wejścia z zewnątrz.
mam takie ustawienia
supla-02.jpg
supla-02.jpg (98.27 KiB) Viewed 508 times
Kto pyta nie błądzi:))
cino111
Posts: 707
Joined: Mon May 07, 2018 8:00 pm

Tue Mar 05, 2019 7:58 pm

Zobacz port tiggering. Tam powinieneś to wpisać.
Post Reply