RGB Remote

Masz pomysł na funkcjonalność lub koncepcję na rozwój projektu. Opisz wszystko tutaj.
Post Reply
User avatar
fracz
Posts: 1585
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Mon May 22, 2017 6:09 am

Ze specjalną dedykacją dla mojego 3-letniego Tomka, który jest niespecjalnie zadowolony z zamiany "normalnego" pilota IR do taśmy led na H801 bo nie jest w stanie ogarnąć suplowego color pickera, przedstawiam SUPLA RGB Remote™ :D
  1. Instalujemy lub aktualizujemy skrypty (viewtopic.php?f=24&p=9678#p9663)
  2. Udajemy się pod adres twojserwer.eu/supla-scripts/rgb/1234 gdzie 1234 to ID kanału ze sterownikiem RGB (można dodać ten adres do jakiejś zakładki dla ułatwienia)
  3. W przeglądarce pokazuje się SUPLA RGB Remote™ do sterowania wybranym kanałem
  4. Po dotknięciu wybranego koloru taśma powinna zmienić kolor
Screenshot_20170522-075223.png
Screenshot_20170522-075223.png (11.29 KiB) Viewed 2171 times
Kolor czarny wyłącza taśmę. Jako bonus - możliwość ustawienia koloru białego na taśmie bez białego (wszystkie diody świecą), czego nie da się zrobić z poziomu aplikacji.

Kolory można sobie dostować jakie się chce tutaj: https://github.com/fracz/supla-scripts/ ... te.php#L30
andras
Posts: 242
Joined: Fri Dec 30, 2016 5:51 pm

Tue May 23, 2017 4:08 pm

Witam

Co może być przyczyną że skrypt się nie wyswietla ?
po wpisaniu https://192.168.1.186/supla-scripts/rgb/23925
dostaję
Not Found

The requested URL /supla-scripts/rgb/23925 was not found on this server.

a https://192.168.1.186/supla-scripts/rgb ... nnel=23925
wyswietla pustą stronę


katalog prawidłowy

https://192.168.1.186/supla-scripts/rgb/ mam

Index of /supla-scripts/rgb
[ICO] Name Last modified Size Description
[PARENTDIR] Parent Directory -
[ ] remote.php 2017-05-21 23:16 2.0K
[ ] rgb.php 2017-05-21 23:16 266

wyswietlanie temperatury działa mi normalnie .
User avatar
fracz
Posts: 1585
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Tue May 23, 2017 4:29 pm

AllowOverride dla katalogu ustawione na all?

Zobacz tutaj: viewtopic.php?f=9&t=2045&p=9723#p9723
andras
Posts: 242
Joined: Fri Dec 30, 2016 5:51 pm

Tue May 23, 2017 7:09 pm

czy o to chodzi ?
root@raspberrypi:/var/www/html/web/supla-scripts# a2enmod rewrite
Module rewrite already enabled , bo nie pomaga
User avatar
fracz
Posts: 1585
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Tue May 23, 2017 7:51 pm

Przeczytaj "Wstępne wymagania" tutaj: viewtopic.php?f=24&t=2102#p9663
andras
Posts: 242
Joined: Fri Dec 30, 2016 5:51 pm

Tue May 23, 2017 8:53 pm

Czytałem kilka razy i już nic nie mogę wymyśleć

dodałem do /etc/apache2/sites-available/000-default.conf
<Directory "/var/www">
AllowOverride All
</Directory>

teraz jest
DocumentRoot /var/www/

<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>

<Directory /var/www>
AllowOverride All
</Directory>

<Directory /var/www/redirect>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>
skrypty mam w /var/www/html/web/supla-scripts , gdzieś popełniłem błąd ale nie wiem gdzie :(
moondec
Posts: 28
Joined: Sun Oct 30, 2016 7:54 pm

Tue May 23, 2017 9:44 pm

A u mnie się załadowała strona z kafelkami tylko nic się nie przełącza. Trochę tak jakby kanał był zły, ale jest dobry. Ustawienia serwera są poprawne bo inne rzeczy (switch) działają. Jakieś pomysły?
moondec
Posts: 28
Joined: Sun Oct 30, 2016 7:54 pm

Tue May 23, 2017 10:04 pm

moondec wrote:
Tue May 23, 2017 9:44 pm
A u mnie się załadowała strona z kafelkami tylko nic się nie przełącza. Trochę tak jakby kanał był zły, ale jest dobry. Ustawienia serwera są poprawne bo inne rzeczy (switch) działają. Jakieś pomysły?
A jednak zły kanał dla RGB ze ściemniaczem to ta druga liczba. Teraz to oczywiste.
andras
Posts: 242
Joined: Fri Dec 30, 2016 5:51 pm

Wed May 24, 2017 7:31 am

Zrobiłem ponowną instalacje według opisu i działa :)
widocznie gdzieś był błąd :)
Post Reply