Wgrywanie na Yunshan przez Arduino

User avatar
klew
Posts: 8774
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

Czy ktoś wgrywał coś na Yunashana przez Arduino ide?

Do tej pory szedłem na łatwiznę i wgrywałem soft na układy z USB. Kupiłem ostatnio Yunshana i próbuję wgrać cokolwiek z Arduino.

Programator (USB TTL, USB-STC-1SP) się wykrył i zainstalował jako nowy port COM 15. Podłączyłem TX-RX oraz RX-TX. GND do GND. Zasilanie do yunshana dałem 12 V niezależnie.
Programator zdaje się działać - coś na serialu odbieram z jakiegoś domyślnego programu (wyświetla się READY, OK, OK).
Zworkę ustawiam na programowanie.
Próbwałem też zasilić układ z 5V z USB, ale po yunshan startuje i po kilku sekundach się wyłącza.

Code: Select all

Global variables use 33084 bytes (40%) of dynamic memory, leaving 48836 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.8
Serial port COM15
Connecting........_____....._____....._____....._____....._____....._____.....____Traceback (most recent call last):
....backtrace removed...
    raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
_
the selected serial port _
 does not exist or your board is not connected
Macie jakieś pomysły co mogę robić źle?
Widzimy się na Supla Offline Party vol. 2 :!:
szym3k
Posts: 268
Joined: Mon May 15, 2017 10:32 am

Post

Próbowałeś testowo wgrywać przez esp download tool?

Yunashan jest bardzo "wrażliwy" na napięcie - mi nie flashuje tych modułów na zasilaczu 12V/1A od jakiegoś routera, ani 9V/2A (też od jakiegoś switcha/routera). Ale mam jeden 19V/3.56A i tam za każdym razem przechodzi flashowanie bez problemu.

Ogólnie moduł kapryśny pod względem zasilania ale u mnie 4 sztuki działają już prawie dwa lata w garażach i nie ma z nimi najmniejszych problemów na sofcie @Zybi - są totalnie bezobsługowe, czego nie mogę powiedzieć jak testowo zainstalowałem na jednego multiboard
User avatar
lukfud
Posts: 2119
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Post

szym3k wrote: Tue Feb 04, 2020 12:10 am Yunashan jest bardzo "wrażliwy" na napięcie - mi nie flashuje tych modułów na zasilaczu 12V/1A od jakiegoś routera, ani 9V/2A (też od jakiegoś switcha/routera). Ale mam jeden 19V/3.56A i tam za każdym razem przechodzi flashowanie bez problemu.
mój ruszył na 12V/1A i zsuplowany przez IDE działa stabilnie.
klew wrote: Tue Feb 04, 2020 12:03 am Programator zdaje się działać - coś na serialu odbieram z jakiegoś domyślnego programu (wyświetla się READY, OK, OK).
mi też coś takiego pokazywał.
https://www.facebook.com/groups/supladiy/
User avatar
klew
Posts: 8774
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

lukfud wrote: Tue Feb 04, 2020 7:12 pm
mój ruszył na 12V/1A i zsuplowany przez IDE działa stabilnie.
Coś trzeba jakoś szczególnie ustawiać w ustawieniach płytki? Ja dałem generic ESP8266 i nic więcej nie zmieniałem
Widzimy się na Supla Offline Party vol. 2 :!:
User avatar
lukfud
Posts: 2119
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Post

klew wrote: Tue Feb 04, 2020 7:17 pm Coś trzeba jakoś szczególnie ustawiać w ustawieniach płytki? Ja dałem generic ESP8266 i nic więcej nie zmieniałem
Nie, domyślne ustawienia Generic ESP8266
Jak podłączasz zasilanie ze zworką to masz na serialu taki wynik?

Image
Last edited by lukfud on Thu Feb 06, 2020 10:09 am, edited 1 time in total.
https://www.facebook.com/groups/supladiy/
User avatar
klew
Posts: 8774
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

lukfud wrote: Tue Feb 04, 2020 7:34 pm
klew wrote: Tue Feb 04, 2020 7:17 pm Coś trzeba jakoś szczególnie ustawiać w ustawieniach płytki? Ja dałem generic ESP8266 i nic więcej nie zmieniałem
Nie, domyślne ustawienia Generic ESP8266
Jak podłączasz zasilanie ze zworką to masz na serialu taki wynik?

Image
Nie jestem teraz przy kompie, ale mniej więcej coś takiego się pojawiało gdy startowałem ze zworką.
Widzimy się na Supla Offline Party vol. 2 :!:
Patryk
Posts: 2713
Joined: Mon Jan 07, 2019 7:51 pm
Location: Rybnik

Post

Wgraj sobie w ramach testu gotowca.
Tu masz program:
https://redirect.viglink.com/?format=go ... v3.6.8.zip
Tu masz instrukcje:
 viewtopic.php?p=49787#p49787
Tu gotowca:
 viewtopic.php?p=52955#p52955
User avatar
lukfud
Posts: 2119
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Post

Albo spróbuj wgrać coś na inne ESP..
https://www.facebook.com/groups/supladiy/
User avatar
Duch__
Posts: 1796
Joined: Wed Aug 24, 2016 7:26 pm
Location: Opole

Post

Zrób zdjęcie dokładne płytki od strony elementów. Mam jedno podejrzenie które mnie się trafiło z modułem YUNSHAN.
Image
User avatar
klew
Posts: 8774
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

szym3k wrote: Tue Feb 04, 2020 12:10 am Próbowałeś testowo wgrywać przez esp download tool?
lukfud wrote: Tue Feb 04, 2020 8:48 pm Albo spróbuj wgrać coś na inne ESP..
Patryk wrote: Tue Feb 04, 2020 8:03 pm Wgraj sobie w ramach testu gotowca.
Dzięki za rady, ale bez sukcesów ;)
Wcześniej próbowałem na zasilaczu 12 V (1,25A). Teraz dałem go na 24 V (2,5 A). Zachowanie identyczne.

Ściągnąłem tego "flash download tool" i widzę identyczne zachowanie jak pod arduino:

Code: Select all

CONNECT BAUD: 115200
============
....._____....._____....._____....._____....._____....._____....._____....._____
....._____....._____[2020-02-05 00:13:31,903][ESP8266Loader_spi[1]][espDownloade
r.py][line:368][ERROR]: Chip sync error: Failed to connect to ESP8266: Timed out
 waiting for packet header
[2020-02-05 00:13:31,903][ESP8266Loader_spi[1]][espDownloader.py][line:459][ERRO
R]: ESP8266 Chip sync error esp_sync_blocking.
Jedyny inny ESP8266 jaki mam, to Wemos D1. Podpiąłem go pod ten programator i efekt mam taki sam. W sumie gdy odłączam pin tx z programatora, to widzę identyczne błędy.

Prawdopodobnie winny okazał się mój programator... Po uważnym przyjrzeniu się układowi, wygląda tak, jakby linia TX nie była przylutowana.
IMG_20200205_011104.jpg
You do not have the required permissions to view the files attached to this post.
Widzimy się na Supla Offline Party vol. 2 :!:

Return to “Yunshan wi-fi relay module”