SONOFF

gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Thu Jul 06, 2017 7:22 am

should I replace the esp_init_data_default.bin with boot.bin?

User avatar
pzygmunt
Posts: 6437
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: SONOFF

Post by pzygmunt » Thu Jul 06, 2017 7:47 am


gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Thu Jul 06, 2017 11:16 am

I flashed the esp_init_data_defalut.bin and then flashed the firmware. Results were same. It did't boots up.

User avatar
pzygmunt
Posts: 6437
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: SONOFF

Post by pzygmunt » Thu Jul 06, 2017 1:09 pm

Flash parameters ?
Memory address for esp_init_data_default ?

gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Fri Jul 07, 2017 12:39 pm

I flashed nodemcu at 0x3fc000.

User avatar
pzygmunt
Posts: 6437
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: SONOFF

Post by pzygmunt » Fri Jul 07, 2017 12:40 pm

Flash Size ?
SPI mode ?

gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Fri Jul 07, 2017 12:51 pm

flash size 4MB and SPI mode QIO.

User avatar
pzygmunt
Posts: 6437
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Re: SONOFF

Post by pzygmunt » Fri Jul 07, 2017 12:55 pm

This firmware
https://github.com/zchmielak/ESP8266/bl ... 2.0_p5.rar

is compiled for 1MB flash size so just change your settings to

FLASH SIZE 8 Mbit (1MByte)

and write esp_init_data to 0xfc000

gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Thu Jul 13, 2017 10:07 am

It worked. But whenever I flash the firmware I have to flash esp_init_data_default.bin. Is it necessary or I am missing something? Thank you for the help. :)

gaurav
Posts: 82
Joined: Mon May 08, 2017 9:49 am

Re: SONOFF

Post by gaurav » Sat May 12, 2018 12:13 pm

I built the sonoff socket firmware from SDK and changed the led port from gpio 13 to gpio 15 and flashed the firmware in nodemcu now the led is glowing continuously instead of blinking in config mode. Why is it so?

Post Reply