Raspberry PI - Instalacja dockerowa

Moderator: fracz

User avatar
pzygmunt
Posts: 6001
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Mon Sep 17, 2018 12:28 pm

bialy wrote:
Mon Sep 17, 2018 12:27 pm
Nic ciekawego nie widać w logach, ale podłączę w wolnej chwili.
Logi od Symfony sprawdź. prod.log
bialy
Posts: 5
Joined: Mon Sep 17, 2018 10:45 am

Mon Sep 17, 2018 12:38 pm

Mogę jeszcze dorzucić kwestię błędu przy zakładaniu nowego usera.
Kiedy skonfiguruję suplę na innych portach, poza 80 i 443, pomimo dopisania w .env domeny i portu (domena.com:port) przy próbie przejścia do strony https://domena.com/register?lang=pl po domenie nie pojawia się numer portu i konto można założyć po ręcznym dopisaniu numeru portu. Powinno się wyświetlić: https://domena.com:port/register?lang=pl. Poza tym port pojawia się na wszystkich stronach.
Supla stoi za firewallem z przekierowaniem portów.

Przy zakładaniu konta tcpdump rejsteruje połączenie smtp:

pi@raspberrypi:~ $ sudo tcpdump -lqni wlan0 port 587
14:25:07.957242 IP 192.168.2.16.36976 > 46.45.127.251.587: tcp 0
14:25:07.973594 IP 46.45.127.251.587 > 192.168.2.16.36976: tcp 0
14:25:07.973782 IP 192.168.2.16.36976 > 46.45.127.251.587: tcp 0
14:25:18.039493 IP 46.45.127.251.587 > 192.168.2.16.36976: tcp 69
14:25:18.039768 IP 192.168.2.16.36976 > 46.45.127.251.587: tcp 0
14:25:18.042407 IP 192.168.2.16.36976 > 46.45.127.251.587: tcp 22
...
14:25:18.503878 IP 46.45.127.251.587 > 192.168.2.16.36976: tcp 46
14:25:18.504188 IP 46.45.127.251.587 > 192.168.2.16.36976: tcp 0
14:25:18.505142 IP 192.168.2.16.36976 > 46.45.127.251.587: tcp 0
14:25:18.521350 IP 46.45.127.251.587 > 192.168.2.16.36976: tcp 0

Przy próbie odzyskania hasła tcpdump milczy, tak jakby mailer nie próbował nawiązać połączenia.
bialy
Posts: 5
Joined: Mon Sep 17, 2018 10:45 am

Mon Sep 17, 2018 8:49 pm

Jak uruchomić logowanie Symfony, żebym mógł coś podesłać.
bialy
Posts: 5
Joined: Mon Sep 17, 2018 10:45 am

Sat Sep 22, 2018 6:15 pm

Za cholerę nie mogę znaleźć logów mailera (Symphony), może ktoś podpowie gdzie je znaleźć?
Simono
Posts: 194
Joined: Mon Sep 17, 2018 5:26 pm

Mon Oct 01, 2018 12:15 pm

Koledzy jak rozwiązać problem z tym iż nie wszystko dobrze startuje po reboot lub halt. Czasami muszę dać reboot ze trzy razy aby wszystko zatrybiło na Raspberry Pi3 oczywiście?
User avatar
pzygmunt
Posts: 6001
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Mon Oct 01, 2018 12:18 pm

Simono wrote:
Mon Oct 01, 2018 12:15 pm
Koledzy jak rozwiązać problem z tym iż nie wszystko dobrze startuje po reboot lub halt. Czasami muszę dać reboot ze trzy razy aby wszystko zatrybiło na Raspberry Pi3 oczywiście?
Jak nie wrzucisz jakiś logów to pozostaje wróżenie z fusów.
Simono
Posts: 194
Joined: Mon Sep 17, 2018 5:26 pm

Mon Oct 01, 2018 12:53 pm

OK tylko jakie logi mam wrzucić po restarcie maliny i po jakim czasie od restartu jak nie będzie działać (teraz cały czas działa jak zrobiłem trzeci restart jakieś ze 30 minut temu). Tak jakby coś nie zawsze zdążało wstać i mam wrażenie, że msql. Z wystawionych portów prze malinę widać wtedy tylko ssh i dwa porty cypres (brak 80 i 443) lub mam tylko ssh.
User avatar
pzygmunt
Posts: 6001
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Mon Oct 01, 2018 1:12 pm

No to się po błędnym restarcie zaloguj i sprawdź co nie działa.
User avatar
fracz
Posts: 1489
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Mon Oct 01, 2018 8:16 pm

Czytaj tu i dalej: viewtopic.php?p=18448#p18448
Simono
Posts: 194
Joined: Mon Sep 17, 2018 5:26 pm

Tue Oct 02, 2018 6:52 am

Dzięki luknę wieczorkiem i sprawdzę jakie rezultaty robiąc w końcu najpierw offline backup karty SD.
Post Reply