[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

tijo
Posty: 168
Rejestracja: pt gru 01, 2017 12:44 pm

śr cze 26, 2019 8:53 am

Walcze...dam znać..
Awatar użytkownika
lesny8
Posty: 1207
Rejestracja: pn gru 11, 2017 9:43 pm

śr cze 26, 2019 8:54 am

tijo pisze:
śr cze 26, 2019 8:17 am

Kod: Zaznacz cały

pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Ign:3 https://download.docker.com/linux/raspbian 10 InRelease
Err:4 https://download.docker.com/linux/raspbian 10 Release
404 Not Found [IP: 52.84.198.41 443]
Reading package lists... Done
E: The repository 'https://download.docker.com/linux/raspbian 10 Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
pi@raspberrypi:~ $
Widzę, że i tak jest lepiej niż miałeś wczoraj, bo pobiera Ci relase file dla repo raspbiana. Wyedytuj plik tak jak @pzygmunt poradził

Kod: Zaznacz cały

sudo nano /etc/apt/sources.list
usuń ten ostatni wpis

Kod: Zaznacz cały

https://download.docker.com/linux/raspbian 10 Release
i daj zrób update i upgrade, a potem leć dalej z dockerem i docker-compose.
tijo
Posty: 168
Rejestracja: pt gru 01, 2017 12:44 pm

śr cze 26, 2019 9:25 am

mój plik sources.list wygląda tak:

Kod: Zaznacz cały

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
Awatar użytkownika
lesny8
Posty: 1207
Rejestracja: pn gru 11, 2017 9:43 pm

śr cze 26, 2019 10:12 am

A co masz w /etc/apt/sources.list.d/docker.list ?

Kod: Zaznacz cały

pi@raspberrypi:~ $ cat /etc/apt/sources.list.d/docker.list
deb [arch=armhf] https://download.docker.com/linux/raspbian stretch stable
tijo
Posty: 168
Rejestracja: pt gru 01, 2017 12:44 pm

śr cze 26, 2019 1:24 pm

lesny8 pisze:
śr cze 26, 2019 10:12 am
A co masz w /etc/apt/sources.list.d/docker.list ?

Kod: Zaznacz cały

pi@raspberrypi:~ $ cat /etc/apt/sources.list.d/docker.list
deb [arch=armhf] https://download.docker.com/linux/raspbian stretch stable
no właśnie tak mam...
Awatar użytkownika
pzygmunt
Posty: 8852
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr cze 26, 2019 1:35 pm

Tak dla jasności. Używasz aktualnego obrazu ?
https://www.raspberrypi.org/downloads/raspbian/
tijo
Posty: 168
Rejestracja: pt gru 01, 2017 12:44 pm

śr cze 26, 2019 1:52 pm

pzygmunt pisze:
śr cze 26, 2019 1:35 pm
Tak dla jasności. Używasz aktualnego obrazu ?
https://www.raspberrypi.org/downloads/raspbian/
używałem tego z pierwszego posta...ściągam teraz

Raspbian Buster Lite
Minimal image based on Debian Buster
Version: June 2019
Release date: 2019-06-20
Kernel version: 4.19
Size: 426 MB

ale to chyba nic nie da....przecież noobs ściąga nowego raspbiana....miałem instalację online...
superprzemo
Posty: 64
Rejestracja: czw maja 09, 2019 6:52 am

czw cze 27, 2019 10:27 am

Ja 3 tygodnie temu instalowałem na RPI 3 B+ tylko bez proxy i teraz wszystko śmiga, tylko parę razy musiałem powtarzać polecenia, bo czasami wywalało mi błędy.
Moja wersja systemu:

Kod: Zaznacz cały

Linux raspberrypi 4.19.42-v7+ #1219 SMP Tue May 14 21:20:58 BST 2019 armv7l
tijo
Posty: 168
Rejestracja: pt gru 01, 2017 12:44 pm

czw cze 27, 2019 10:29 am

superprzemo pisze:
czw cze 27, 2019 10:27 am
Ja 3 tygodnie temu instalowałem na RPI 3 B+ tylko bez proxy i teraz wszystko śmiga, tylko parę razy musiałem powtarzać polecenia, bo czasami wywalało mi błędy.
Moja wersja systemu:

Kod: Zaznacz cały

Linux raspberrypi 4.19.42-v7+ #1219 SMP Tue May 14 21:20:58 BST 2019 armv7l
u mnie cały czas wyskakuje że nie ma dockera dla rapsbiana 10
Awatar użytkownika
pzygmunt
Posty: 8852
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

czw cze 27, 2019 10:34 am

Ostatnie instalowałem na tym samym sprzęcie. Zainstalowało się bez problemu. Gdzieś popełniasz błąd.
Postaw czysty OS i udostępnij mi to raspberry albo wystawiając port 22 albo przez teamviewer-a
ODPOWIEDZ

Wróć do „FAQ / Jak to zrobić”